Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-08-2013, 03:56 AM   #1
New Camper
 
Join Date: May 2013
Location:
Posts: 1
I have a ZT33BH travel trailer and I can't see to figure out why my radio unit will not power on. I have checked all of my breakers and fuses and everything is in working order. So far the Radio seems to be the only component that does not get power.



Can someone help my out in troubleshooting this issue.



Thanks

Pascal
ACBlast is offline   Reply With Quote
Old 05-08-2013, 05:39 AM   #2
Seasonal Camper
 
Beamer5's Avatar
 
Join Date: Feb 2013
Location: United States
Posts: 285
Should be pretty easy to pull the unit out and check all the connections in back. I have heard of some coming loose in transit.
__________________
2015 GMC Sierra 1500 Crew Cab Z71 4X4 3.42
2013 CrossRoads Sunset Trail Super Lite 250RB
Beamer5 is offline   Reply With Quote
Old 05-08-2013, 10:55 AM   #3
Full Time Camper
 
anaro's Avatar
 
Join Date: Jan 2011
Location: Mebane, NC
Posts: 2,394


There is a separate fuse for the radio. You have to pull the radio to find it. Check that fuse.
__________________

2014 Chevy Silverado 3500 SRW Duramax
2011 Zinger ZT26BL-sold
2014 Sabre 34REQS

***Member of the Mason-Dixon Group***
anaro is offline   Reply With Quote
Old 07-02-2013, 11:00 AM   #4
New Camper
 
SunsetKeni's Avatar
 
Join Date: Mar 2011
Location: Broomfield, CO
Posts: 9
Anaro - you saved us I don't know how many summers with no radio before we could afford to haul our trailer in for repair (then to be ripped off because it was only a fuse). We took the trailer out of storage and then hooked up the batteries backwards (apparently red and black are both positive, lol) - replaced the blown fuses and then cursed when we discovered the radio (also the surround sound + DVD player) was not turning on. In desperation I started googling and found this post. Our family is soooo grateful!
__________________
2012 Dodge RAM 2500 Laramie Hemi, 2010 Crossroads Sunset Trail ST29QB
SunsetKeni is offline   Reply With Quote
Old 07-02-2013, 11:31 AM   #5
Full Time Camper
 
anaro's Avatar
 
Join Date: Jan 2011
Location: Mebane, NC
Posts: 2,394
Quote:
Originally Posted by SunsetKeni
Anaro - you saved us I don't know how many summers with no radio before we could afford to haul our trailer in for repair (then to be ripped off because it was only a fuse). We took the trailer out of storage and then hooked up the batteries backwards (apparently red and black are both positive, lol) - replaced the blown fuses and then cursed when we discovered the radio (also the surround sound + DVD player) was not turning on. In desperation I started googling and found this post. Our family is soooo grateful!

You're welcome. I'll give you one guess how we blew that radio fuse in the first place. Yup you guessed it, backwards on the battery hookup. I suggest labeling them for future use. We now only disconnect one side unless removing the battery.
__________________

2014 Chevy Silverado 3500 SRW Duramax
2011 Zinger ZT26BL-sold
2014 Sabre 34REQS

***Member of the Mason-Dixon Group***
anaro is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 06:35 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.