Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-04-2019, 04:57 AM   #1
New Camper
 
Join Date: May 2018
Location: Newfoundland and Labrador
Posts: 3
2013 Sunset 29SS No power

Hey,
I just took our trailer out of storage. Everything was working fine when I put it away.

Issue :
I have no power to my outside outlets, fireplace, stero and furnace. Everything else in the trailer is working. I checked to see if a gfci was popped but it isn't.
I checked all fuses and breakers in the panel box all looks good

Is there any other fuses, plugs etc that I should be looking at?

When I hooked the battery up, I did hook it up in reverse and popped the two fuses which I replaced and everything works fine except the above.

Cant seem to find a wiring schematic

Any suggestions would be great

Thanks
Tyson10 is offline   Reply With Quote
Old 05-04-2019, 06:22 AM   #2
Site Team
 
Join Date: Dec 2007
Location: WI.
Posts: 7,470
That has happened to quite a few .
Here is a link.



CrossRoads RV Family Forum - Search Results
__________________
2008 Cruiser CF26RK
2013 Ford Eco-Boost
Heavy duty payload - Max tow
Lloyd is offline   Reply With Quote
Old 05-04-2019, 08:56 AM   #3
Weekend Camper
 
Join Date: Apr 2018
Location: NY
Posts: 26
Stereo and furnace would be 12V. Outside outlets are 110 only. Not sure about fireplace - if propane would be 12V, if electric would be 110V. Odd that both sides would go out. I had read somewhere that there is a reverse polarity protection fuse somewhere on the converter. Is it one that you replaced?
__________________
Joe Munson
2011 Chevy 1500 SB 4x4 5.3L w/trailer tow
2013 Zinger ZT23FB
Reese Weight Dist. w/friction sway control
jmnsn57 is offline   Reply With Quote
Old 05-05-2019, 06:27 PM   #4
Weekend Camper
 
Join Date: Jul 2018
Location: Minnesota
Posts: 59
Lloyd, the link you provided is no good.
__________________
Doug and Patience and Shelby the mutt
2015 Crossroads Sunset Trail Reserve ST26RB
2005 Ford F-150 Lariet Supercab 4x4
Wingerdinger is offline   Reply With Quote
Old 05-05-2019, 06:40 PM   #5
Site Team
 
Join Date: Dec 2007
Location: WI.
Posts: 7,470
That's peculiar. It worked when I previewed it.
Will try again.
http://www.crossroadsowners.com/foru...tat-10155.html
http://www.crossroadsowners.com/foru...ards-6189.html
__________________
2008 Cruiser CF26RK
2013 Ford Eco-Boost
Heavy duty payload - Max tow
Lloyd is offline   Reply With Quote
Old 05-05-2019, 06:44 PM   #6
Site Team
 
Join Date: Jun 2015
Location: mo
Posts: 454
The outside outlets and fireplace are 110 v. so check all the GFI outlets. Could be the kitchen or the bath. The radio and furnace are 12 v . The radio may have a fuse behind it and the thermostat may have a fuse in it or behind it. Also on the GFCI s try to trip them as sometimes they look ok but need to be reset.
__________________
2005 Cruiser 29CK
2008 GMC 2500hd 4x4
Crew cab Long bed 6.0 gas
4.10 gear ratio
dagst1 is offline   Reply With Quote
Old 05-06-2019, 08:09 AM   #7
New Camper
 
Join Date: May 2018
Location: Newfoundland and Labrador
Posts: 3
Thanks for the reply

Update:
Changed every fuse in the trailer and now everything works except one plug which is the one the fireplace plugs into.

Tested the plug, there is power going to the plug so I'm thinking the plug needs changing.

Lesson learned: Even when the fuse's don't look blown change anyway. Very inexpensive and saves a lot of headache.
Tyson10 is offline   Reply With Quote
Old 05-06-2019, 04:16 PM   #8
Full Time Camper
 
harley's Avatar
 
Join Date: Aug 2012
Location: Belle River , Ontario
Posts: 1,582
There is nothing wrong with the fireplace plug...just switch from "water heater " to "fireplace" on panel and fireplace plug will work...it is one or the other...
__________________


It was a rainy few days at Algonquin Prov park...tarps kept us dry.
Wayne --Belle River (Windsor), Ontario
2013 Sunset Trail Reserve 25RB..
2015 White Chev Silverado 2500HD 4x4 (6.0 l gasser)
2003 Mountain Star 890SBRX Truck Camper
harley is offline   Reply With Quote
Old 05-06-2019, 06:46 PM   #9
Site Team
 
Join Date: Dec 2007
Location: WI.
Posts: 7,470
Good catch harley.
I didn't think about that. I should've tho. I use to have a class c that was either the AC or the microwave.
__________________
2008 Cruiser CF26RK
2013 Ford Eco-Boost
Heavy duty payload - Max tow
Lloyd is offline   Reply With Quote
Old 05-06-2019, 07:07 PM   #10
New Camper
 
Join Date: May 2018
Location: Newfoundland and Labrador
Posts: 3
Harley, wish it was that easy. The switch is already on fir the fireplace

Thanks tho
Tyson10 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 04:25 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.