Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-18-2016, 12:44 PM   #1
New Camper
 
Join Date: Jul 2016
Location: Ca
Posts: 1
Unhappy Cold water back half of trailer Not working

I went camping this week and come find out my cold water for the Shower, toilet and outside kitchen were not running. All other water faucets and lines were fine and flowing. I looked at all the obvious areas and opened a few access ports to check for kinks, all was good. I disconnected the water line to the toilet while the water was on and nothing. No leaks! I hate to have to take it in and I hate to have to take the under belly apart but I thinks those are my only two options.

BLAZING HOT SHOWERS SUCK!
Bustaphi is offline   Reply With Quote
Old 07-18-2016, 01:41 PM   #2
Site Team
 
Join Date: Dec 2007
Location: WI.
Posts: 7,679
What do you have for a trailer? Year, make, and model.
If you put that info in your signature people will have a better idea on how to answer you.
__________________
2008 Cruiser CF26RK
2013 Ford Eco-Boost
Heavy duty payload - Max tow
Lloyd is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 10:57 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×