Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-03-2012, 12:44 PM   #1
Weekend Camper
 
Join Date: Sep 2012
Location:
Posts: 33
After wasting a whole day on the phone. I finally got an answer and passed on to Crossroads.
I have a 2012 Sunset ST32FR layout. I took delivery of it Two weeks ago. I pulled down the AC filter to notice it was held their buy Two Rubber Bands and flapping around and letting in unfiltered air. I added Two more Rubber Bands and hopefully that will solve the problem.
Now for the Bigger Problem When you look up after removing the filter on the right hand side their is light showing through in about 4 or 5 spots. This represents outside air being sucked in and in my case living in Florida I have hot air being sucked in. It took a whole day of phone calls to find out the reason for the holes. They were put their by Dometic in order to mount a heat strip which is not my case or probably not most of yours. These holes should have been plugged up by the AC installer at Crossroads if a heat strip is not used in the AC unit according to a Tech. at Dometic I spoke to today.
My advise is to look and see if you have this issue.




__________________
Bruce
momojito is offline   Reply With Quote
Old 10-10-2012, 03:09 AM   #2
Weekend Camper
 
Join Date: Sep 2012
Location:
Posts: 33


Quote:
Originally Posted by momojito
After wasting a whole day on the phone. I finally got an answer and passed on to Crossroads.
I have a 2012 Sunset ST32FR layout. I took delivery of it Two weeks ago. I pulled down the AC filter to notice it was held their buy Two Rubber Bands and flapping around and letting in unfiltered air. I added Two more Rubber Bands and hopefully that will solve the problem.
Now for the Bigger Problem When you look up after removing the filter on the right hand side their is light showing through in about 4 or 5 spots. This represents outside air being sucked in and in my case living in Florida I have hot air being sucked in. It took a whole day of phone calls to find out the reason for the holes. They were put their by Dometic in order to mount a heat strip which is not my case or probably not most of yours. These holes should have been plugged up by the AC installer at Crossroads if a heat strip is not used in the AC unit according to a Tech. at Dometic I spoke to today.
My advise is to look and see if you have this issue.
If you have this AC Issue Could you post it here?



__________________
Bruce
momojito is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 06:38 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×