Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-09-2012, 11:51 AM   #1
New Camper
 
Join Date: Jul 2012
Location: Kapuskasing ON
Posts: 9
Hi everyone, i have 2011 sunset trail 29qb and took my RV hunting over the weekend with the family. The furnace was working properly but then I noticed a problem. The furnace would start, heat would come out, then shut off within 30 even with the thermostat at the highest temperature. Then, the furnace would start again and do the same thing. This happened all night and It got cold in the RV.



Any help would be appreciated.

Filly12 is offline   Reply With Quote
Old 10-10-2012, 03:40 AM   #2
Weekend Camper
 
Join Date: Sep 2012
Location:
Posts: 52
I don't really know where to start with the issue, but it seems like some kind of fault detecting circuit is finding a fault and shutting it down, or else the temp sensor in the thermostat is sitting RIGHT beside a vent?

I would say that it will need to be brought in to a dealer to be checked. Gas flow scares me personally.




wikdslo is offline   Reply With Quote
Old 10-10-2012, 04:05 AM   #3
Family Vacation Member
 
Tonemeister's Avatar
 
Join Date: Jan 2012
Location: Ontario
Posts: 104
I remember when we used the furnace for first time this past February on our trip south to Florida, furnace would be cycling on & off quite a bit. On the ST25RB they placed the furnace floor vent right under and about a foot away from the thermostat. I ended up removing floor register & covering 1/2 of vent blowing towards thermostat with cardboard, (then putting register back) thus forcing air towards the other side away from thermostat. Works absolutely fine now. This may be your issue as well. Good luck. Edited by: Tonemeister
__________________
Nancy + Tony
'11 Dodge Laramie Longhorn CC
'12 Sunset Trail ST25RB
Equal-i-zer hitch
Tonemeister is offline   Reply With Quote
Old 10-10-2012, 08:54 AM   #4
Weekend Camper
 
Join Date: Aug 2012
Location:
Posts: 22




I am sure you have checked the exhaust site for your furnace? If plugged or partly obstructed it is telling the furance it is overheated and it shuts down...just a thought
Zinger2012 is offline   Reply With Quote
Old 10-10-2012, 09:35 AM   #5
Family Vacation Member
 
Roadie66's Avatar
 
Join Date: Jul 2012
Location: BC Canada
Posts: 154
x2 with Tonemeister.......had exactly the same problem and exactly the same fix!!!!!
Quick and easy




__________________

Home is where the hookup is.
2012 ST25RB Reserve tailgating a 2011 Chev Silverado 2500HD Duramax
Roadie66 is offline   Reply With Quote
Old 10-10-2012, 10:18 AM   #6
Family Vacation Member
 
Roadie66's Avatar
 
Join Date: Jul 2012
Location: BC Canada
Posts: 154
Don't wanna hijack but...
Anybody with a Sunset Trail Reserve you might want to have a look at this topic http://www.crossroadsrv.com/forum/fo...ID=51356#51356 as there are a few other issues with our type of trailer coming up.



__________________

Home is where the hookup is.
2012 ST25RB Reserve tailgating a 2011 Chev Silverado 2500HD Duramax
Roadie66 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 04:08 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.