Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-27-2013, 11:38 AM   #1
Weekend Camper
 
tkinley8193's Avatar
 
Join Date: Sep 2013
Location: south carolina
Posts: 12


just bought a st270bh we took it out for the first run last week end to Pigeon forge . In our old camper we could leave the valve on the grey tank open all the time . But this weekend if I left the valve open the smell from the sewer system came back into the camper. Has anyone experienced this or could it be the sewer system of the campground . Thanks
__________________
Travis
2007 Toyota Tundra 5.7
2014 Sunset Trail ST270BH
tkinley8193 is offline   Reply With Quote
Old 10-27-2013, 12:42 PM   #2
Full Time Camper
 
harley's Avatar
 
Join Date: Aug 2012
Location: Belle River , Ontario
Posts: 1,391
your traps should be stopping all smells from coming back up ...knowing crossroads quality record , they probably forgot to put a trap somewhere ...maybe the shower?thats hidden.
check all your traps and also check the "vent" under your sink ...it may be faulty.
__________________


It was a rainy few days at Algonquin Prov park...tarps kept us dry.
Wayne --Belle River (Windsor), Ontario
2013 Sunset Trail Reserve 25RB..
2015 White Chev Silverado 2500HD 4x4 (6.0 l gasser)
1997 Lance SL 185 Truck Camper (for Yukon/Alaska NWT trip for 2015)
harley is offline   Reply With Quote
Old 10-27-2013, 04:00 PM   #3
Full Time Camper
 
Join Date: Jun 2011
Posts: 1,009
My last one did that. Turns out there was a vent valve under the sink. It wasn't tightened and fell off. Smell. I put it back on and all was well....
__________________
Clif and Millie
Ozzie (half a dog tall & 2 dogs long)
Mabank, TX
2009 Ford Lariat F350 SRW CC Diesel
2013 Cruiser CF305SK Patriot Edition
avvidclif is offline   Reply With Quote
Old 10-28-2013, 05:53 AM   #4
Family Vacation Member
 
jlongsta's Avatar
 
Join Date: Sep 2013
Location: Kansas
Posts: 214



This happened to us this past summer. I realized that we hadn't used the tub/shower and the trap wasdry. As soon as we ran a little water in the down the tub drain, the problem was solved.
Edited by: jlongsta
__________________
Richard and Jill

2013 Sunset Trail Reserve 26RB
2013 F250
jlongsta is offline   Reply With Quote
Old 10-29-2013, 11:13 AM   #5
Full Time Camper
 
coastn's Avatar
 
Join Date: Dec 2007
Location: Breckenridge,CO
Posts: 843


X2
__________________
CAMPGROUND "DRIVEWAY"

Breckenridge, CO
'08 ST30BH Traded
'15 Canyon Trail 31FBHS 5er
'16 Fox Mountain 235 RLS 5er
'14 RAM 2500 4X4 CTD
coastn is offline   Reply With Quote
Old 10-29-2013, 11:40 AM   #6
Weekend Camper
 
tkinley8193's Avatar
 
Join Date: Sep 2013
Location: south carolina
Posts: 12


Thanks for all the advice the vent cap under the bathroom sink had come off it will have to wait until the next trip see if it worked but I fill like it will. That's why I like the forum you can get some pretty good help if you just ask
__________________
Travis
2007 Toyota Tundra 5.7
2014 Sunset Trail ST270BH
tkinley8193 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 12:31 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.