Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-06-2011, 03:36 AM   #1
Weekend Camper
 
Join Date: Apr 2011
Location:
Posts: 11
So we got our 41' Destination trailer about a month ago and Saturday night the power goes out. Not all the power, lights were dimly lit, tv still worked, some lights worked at half power - it was very strange. Had several guys in the campgrounds come over and we trial and errored abunch of things and nothing worked. Finally, we decided to swap out the 1 month old interstate battery and what do you know, everything lit up and the AC kicked on and it was fine.

So, the question is, what is happening? What is draining the battery or not recharging the battery? The inverter? I don't even know what an inverter is, but somebody said that it could be the inverter.

To top it off, we called the dealer where we got the RV and they don't have anyone who can come look at it - I guess we are on our own and have to find our own person to come diagnose and repair and then we submit the receipt to crossroads? Is that correct or how do you guys handle warranty work if you can't take it in? It's a 41' trailer and it stays at the campsite.



Thanks everyone!



Marc
mcp6530 is offline   Reply With Quote
Old 06-06-2011, 03:53 AM   #2
Full Time Camper
 
mwebber78's Avatar
 
Join Date: Jun 2008
Location: Maine
Posts: 1,250
Send a message via Yahoo to mwebber78




A park model is expected to be setup and forget it. Your dealer shouldn't be selling park models if they don't have a traveling repair service. In fact, I can't recall a local dealer to me who doesn't have one! So here is what I'd do, call your local dealer and have them contract out to a local traveling repair service. Crossroads will pay for the warranty, your dealer can pay the premium to the traveling repair service.

Your second option is to call Crossroads, tell them your dealer sold you a unit they can't service and you want to call a traveling repair service to correct the defect. Either way I wouldn't darken the dealers door again after this snafu.
__________________
Mike
2013 Jayco Eagle 334RBTS
Crossroads Forum Lurker
mwebber78 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 04:39 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.