Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-23-2015, 06:54 PM   #1
New Camper
 
Join Date: Jan 2015
Location: Florida
Posts: 8
2015 sunset trail reserve st33fr..heater question

Need some help..my heater was working great until I changed out one of the propane bottles I needed to refill. I fill the bottle, replaced it, turned on the gas, flipped the lever for that bottle, and went to a shooting match for four days. When I returned, I set the thermostate to heat and the temp I needed. When I woke up, the camper was cold. It acts like it's not getting propane. It comes on for a few seconds shooting cold air and then cuts off. That usually happens when the propane bottle is out. I checked my stove to see if it was getting the propane and it works like it should. I know it must be something simple that I need to do to get it going. I just don't know what. If anyone has had this happen I would really like to know what you did and what the problem was. Thank you very much.
Rawhide is offline   Reply With Quote
Old 09-24-2015, 10:20 AM   #2
Full Time Camper
 
Steve7's Avatar
 
Join Date: Sep 2015
Location: Nv
Posts: 624
I know that sometimes there is air in the lines after a change of bottles or lapse of use. This happened to me on my refrigerator I turned on for first time. The instructions were to keep recycling it on and of if it didn't light. It has an automatic shut of switch if it didn't light after three cycles of trying. That's when i turned it off and on. On the fourth time it worked I assume the heaters have a similar safety switch turning the propane off if it doesn't sense propane.
__________________
Steve & Sue
2017 Grand Design 297RSTS Travel Trailer
2017 Ford F-350 Lariat Crew Cab diesel 6.7 SW LB 11,500 lb GVWR package
Former: Crossroads ST26RB
Steve7 is offline   Reply With Quote
Old 09-24-2015, 06:30 PM   #3
New Camper
 
Join Date: Jan 2015
Location: Florida
Posts: 8
Thanks..I did read that and I've tried it. It still doesn't work. The manual said it had a switch and an led light that would indicate a shutdown but we couldn't find the switch or the led light anywhere.
Rawhide is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 01:22 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.