Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-09-2013, 03:22 AM   #1
Seasonal Camper
 
hondavalk's Avatar
 
Join Date: Feb 2013
Location: ohio
Posts: 312
I just noticed the build sheet on my st29s says it should have a Jensen awm970 but in reality it's a awm965. Is this something worth complaining about and any suggestions on who to contact? It a 2013 that's almost 11 months old. Thanks
__________________
hondavalk
2008 Tundra 5.7L
2013 ST29SS
Reese DC
hondavalk is offline   Reply With Quote
Old 06-09-2013, 03:43 AM   #2
Full Time Camper
 
Bert's Avatar
 
Join Date: Mar 2013
Location: Florida
Posts: 646
I had the same problem. I contacted my dealer and sent him pictures of the build sheet and the radio. They shipped me one in the mail. It is worth it.
__________________

Bert, Cathy, Kylie & Kaitlin
2014 SunsetTrail Reserve 32BH
2009 Silverado 3500HD LTZ 4X4 6.6L Duramax
YouTube LetsRV Instagram LetsRV_
Bert is offline   Reply With Quote
Old 06-09-2013, 10:17 AM   #3
Seasonal Camper
 
mnsunset's Avatar
 
Join Date: Feb 2012
Location: minnesota
Posts: 365
I too (along with many others) ended up with the AMW965. The problem is you can't play a movie audio through the TV. Only through all the speakers.
It took several e-mails, phone calls and complaints before The AMW 970 was shipped to me. Customer service at crossroads admitted to me they shipped with the wrong head unit, I was told that person was let go shortly after telling me this.

Anyway, stay on it, they should ship the correct unit.

Good luck.




__________________
2013S22BH/2015 f-150 ecoboost
mnsunset is offline   Reply With Quote
Old 06-09-2013, 12:25 PM   #4
Full Time Camper
 
Tim D's Avatar
 
Join Date: May 2013
Location: So IL
Posts: 1,811
I have the same issue. Anyone specific to address this with?

Very agrivating if you want to watch a movie in bed. Also, there is no seek function when tuning the radio. Mine goes by .2 and have to press again.
__________________

Tim
13 ST25RB
08 F-250 SC 6.8L XLT 4x4
Tim D is offline   Reply With Quote
Old 06-09-2013, 01:42 PM   #5
Seasonal Camper
 
mnsunset's Avatar
 
Join Date: Feb 2012
Location: minnesota
Posts: 365
So its not just me that cant get the unit to "seek"?
I can't remember who I ended up speaking to at crossroads. All I remember is it took a lot of e-mails and finally some phone calls.



__________________
2013S22BH/2015 f-150 ecoboost
mnsunset is offline   Reply With Quote
Old 06-09-2013, 02:24 PM   #6
Weekend Camper
 
logicsrealm's Avatar
 
Join Date: Sep 2012
Location: Virginia
Posts: 32
Go through the "contact us" link on the crossroads home page and fill out the form there with your concern over the radio unit. I emailed them regarding my unit and I had a reply early the next day. A couple emails back and forth in the course of a few hours and my new 970 was in the mail. Have a picture of your build sheet(with VIN), and existing radio handy when you contact them. I suggest using the form on the website because initially I sent an email directly to service@crossroadsrv.com from my Gmail account. The reply I got from Customer Service included the header RE: SPAM: "my original subject line". Indicating that someone happened to dig my email out of their spam folder. This may explain some of the complaints you see in the forum about the lack of response to some emails. If these people are emailing the "service" address the spam filter may be too picky and hiding some of their mail. This was as recent as a couple of weeks ago and the new radio arrived this week.
__________________
Kim & Brent
Front Royal, VA
2013 Sunset Trail 25RB
2006 Ford F-250 6.0L

logicsrealm is offline   Reply With Quote
Old 06-09-2013, 10:35 PM   #7
Seasonal Camper
 
hondavalk's Avatar
 
Join Date: Feb 2013
Location: ohio
Posts: 312

Quote:
Originally Posted by logicsrealm
Go through the "contact us" link on the crossroads home page and fill out the form there with your concern over the radio unit. I emailed them regarding my unit and I had a reply early the next day. A couple emails back and forth in the course of a few hours and my new 970 was in the mail. Have a picture of your build sheet(with VIN), and existing radio handy when you contact them. I suggest using the form on the website because initially I sent an email directly to service@crossroadsrv.com from my Gmail account. The reply I got from Customer Service included the header RE: SPAM: "my original subject line". Indicating that someone happened to dig my email out of their spam folder. This may explain some of the complaints you see in the forum about the lack of response to some emails. If these people are emailing the "service" address the spam filter may be too picky and hiding some of their mail. This was as recent as a couple of weeks ago and the new radio arrived this week.

Thanks for the info
__________________
hondavalk
2008 Tundra 5.7L
2013 ST29SS
Reese DC
hondavalk is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 09:00 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.