Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-10-2016, 02:51 PM   #1
New Camper
 
Join Date: Feb 2014
Location: New Brunswick
Posts: 1
City Water hookup is filling fresh water tank

Hooked up my "City Water" hose last weekend and the following day I noticed water dripping from my "Fresh Water Tank" fill vent. After further investigation, I discovered that my Fresh Water Tank was filled and overflowing, even though I hadn't physically put any water in it.

Is it possible that I left a Fawcett in the wrong position at the end of last season when I winterized it and water is flowing from the city water system back into the fresh water tank? Any ideas?

I have a 2012 Sunset Trail Reserve 32FR.
LandLubber is offline   Reply With Quote
Old 05-10-2016, 03:08 PM   #2
Family Vacation Member
 
Join Date: Jul 2015
Location: Missouri
Posts: 144
Quote:
Originally Posted by LandLubber View Post
Hooked up my "City Water" hose last weekend and the following day I noticed water dripping from my "Fresh Water Tank" fill vent. After further investigation, I discovered that my Fresh Water Tank was filled and overflowing, even though I hadn't physically put any water in it.

Is it possible that I left a Fawcett in the wrong position at the end of last season when I winterized it and water is flowing from the city water system back into the fresh water tank? Any ideas?

I have a 2012 Sunset Trail Reserve 32FR.
Had a similar issue with my last trailer. The check valve on the pump is probably stuck open. Could be a piece of debris like mine was. I ran the pump for several minutes and was able to flush the debris and fix the problem. If that doesn't work, you will probably have to take the pump out and rebuild it. Almost every pump manufacturer sells a rebuild kit and it is actually a fairly easy job, just takes some time and patience.
__________________
2016 Sunset Trail 33BD
Tow Vehicle 2016 Nissan Titan XD 4x4, Crew Cab, SV with Cummins V-8
CFun is offline   Reply With Quote
Old 05-10-2016, 04:16 PM   #3
Site Team
 
Join Date: Dec 2007
Location: WI.
Posts: 7,566
CFun is right.
Here is a link to the same problem.

http://www.crossroadsowners.com/foru...ater-5438.html
__________________
2008 Cruiser CF26RK
2013 Ford Eco-Boost
Heavy duty payload - Max tow
Lloyd is online now   Reply With Quote
Old 05-13-2016, 06:13 AM   #4
Seasonal Camper
 
2slick's Avatar
 
Join Date: Sep 2012
Location: Rockport, TX
Posts: 405
I just went through this issue. I added a spring loaded check valve in line with the pump.


Sent from my iPhone using Tapatalk
__________________
Will

2013 Chevy 3500HD
2012 Rushmore 38CK
2slick is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 06:45 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.