Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-06-2014, 10:17 PM   #1
New Camper
 
Join Date: May 2014
Location: Colorado
Posts: 9
Converter Fan

Converter fan runs almost continuously while hooked to shore power. Is that normal? Just got our 2014 model home, and if more than a couple of lights are on the fan is running all the time...
4nickels is offline   Reply With Quote
Old 05-06-2014, 10:21 PM   #2
Seasonal Camper
 
mnsunset's Avatar
 
Join Date: Feb 2012
Location: minnesota
Posts: 365
same here

Yup, same with mine. Always thought it was strange. Our old TT had a very quite converter. Not this one. You know when its on.
__________________
2013S22BH/2015 f-150 ecoboost
mnsunset is offline   Reply With Quote
Old 05-06-2014, 10:35 PM   #3
Weekend Camper
 
tomandlori's Avatar
 
Join Date: Oct 2013
Location: michigan
Posts: 92
Send a message via Skype™ to tomandlori
If I remember, all the lights run on 12 volt DC. So the converter is changing the 110 volt AC to 12 volt DC.
tomandlori is offline   Reply With Quote
Old 05-07-2014, 05:26 AM   #4
Family Vacation Member
 
TrainSafe's Avatar
 
Join Date: Apr 2012
Location: WI
Posts: 183
Yep, the converter will kick it up a notch when you turn on more load. When I switched all my lights to LED, it helped keep my converter quiet.
__________________
Ted

2013 Sunset Trail 31BH
TrainSafe is offline   Reply With Quote
Old 05-07-2014, 06:55 AM   #5
New Camper
 
Join Date: May 2014
Location: Colorado
Posts: 9
Thanks everyone, wasn't sure if that was normal but it sounds like it is. Just didn't want the battery to burn out...
4nickels is offline   Reply With Quote
Old 05-07-2014, 06:57 AM   #6
Full Time Camper
 
cw3jason's Avatar
 
Join Date: Feb 2013
Location: Connecticut
Posts: 688
Normal. switched to LEDs and no more noisy fan
__________________

Jason & Wendy
2014 Ford F-350 Lariat 6.7L PSD
2015 Keystone Montana 3711FL
B&W Patriot 16K Fifth Wheel Hitch
cw3jason is offline   Reply With Quote
Old 05-07-2014, 08:16 AM   #7
Weekend Camper
 
Camp Wilson's Avatar
 
Join Date: Apr 2014
Location: South Carolina
Posts: 22
Just got my 2015 270BH Saturday and have noticed the same. Was wondering if that was normal too.
Camp Wilson is offline   Reply With Quote
Old 05-07-2014, 09:21 AM   #8
Weekend Camper
 
Join Date: Oct 2013
Location: Nebraska
Posts: 35
Great Post and Great Comments around the LED's. I too switched to LED's about 3 weeks ago and am still amazed that I don't hear the fan anymore. Ranks in the Top 3 Mods that I have completed in MHO.
__________________
2015 Chevy 3500HD Crew Cab
2014 Zinger 33BH
kbravo1974 is offline   Reply With Quote
Old 05-07-2014, 07:22 PM   #9
New Camper
 
Join Date: May 2014
Location: Colorado
Posts: 9
Thanks everyone... guess I'll figure out which replacement LED's I need and get to switching them out.
4nickels is offline   Reply With Quote
Old 05-07-2014, 08:51 PM   #10
Full Time Camper
 
Tim D's Avatar
 
Join Date: May 2013
Location: So IL
Posts: 1,811
Mine too. Depends on how many lights and which ones. Plan to switch to LEDs in the near future. Watching LED thread to get a consensus on which ones to get.
__________________

Tim
13 ST25RB
08 F-250 SC 6.8L XLT 4x4
Tim D is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 09:20 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.