Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-22-2019, 07:02 AM   #1
Weekend Camper
 
Join Date: Mar 2018
Location: Illinois
Posts: 55
Domestic Freezer/Fridge Issues

We have the unit set to auto and plugged into electric. As soon as I turn off the propane the check light starts to flash and the unit stops working instead of running on the electric.
There are only two settings. 1. Auto or 2. Gas.

I donít think itís even utilizing the electric because while we were away I did leave the propane on in the event the electric went out. When I returned the propane was empty, electric on but our fridge/freezer unit was flashing check. No heat or any other items on but my propane tank was empty. As soon as I put a new tank on the unit starts working. I shut the tank off the check light flashes and unit stops working.
This leads me to believe that the unit is never running on electric and only utilizing the gas.
Any thoughts? What should I look at or could the problem be?
__________________
2016 CR Z1 32 bhs
smoke33 is offline   Reply With Quote
Old 09-22-2019, 07:12 AM   #2
Full Time Camper
 
harley's Avatar
 
Join Date: Aug 2012
Location: Belle River , Ontario
Posts: 1,656
Code:
firstthing is to take outside cover off and unplug fromreceptical and plug something in to see it it is getting power to plug.
__________________


It was a rainy few days at Algonquin Prov park...tarps kept us dry.
Wayne --Belle River (Windsor), Ontario
2013 Sunset Trail Reserve 25RB..
2015 White Chev Silverado 2500HD 4x4 (6.0 l gasser)
2003 Mountain Star 890SBRX Truck Camper
harley is offline   Reply With Quote
Old 09-22-2019, 07:17 AM   #3
Weekend Camper
 
Join Date: Mar 2018
Location: Illinois
Posts: 55
Quote:
Originally Posted by harley View Post
Code:
firstthing is to take outside cover off and unplug fromreceptical and plug something in to see it it is getting power to plug.


Thanks for the response. After I turn the gas on and reset the system I can hear the electronic ignition lighting the gas. Wouldnít that indicate there is power to the unit?
__________________
2016 CR Z1 32 bhs
smoke33 is offline   Reply With Quote
Old 09-22-2019, 07:30 AM   #4
Family Vacation Member
 
Join Date: Jun 2018
Location: Mb
Posts: 150
Quote:
Originally Posted by smoke33 View Post
Thanks for the response. After I turn the gas on and reset the system I can hear the electronic ignition lighting the gas. Wouldnít that indicate there is power to the unit?


Indicates 12v power going to unit. Did you check plug as requested and if no power there, the breaker for 110?
__________________
2013 Zinger ZT260BH towed by a 2013 Silverado Z71 1500 CC 5.3L
660catman is online now   Reply With Quote
Old 09-22-2019, 07:33 AM   #5
Weekend Camper
 
Join Date: Mar 2018
Location: Illinois
Posts: 55
Quote:
Originally Posted by 660catman View Post
Indicates 12v power going to unit. Did you check plug as requested and if no power there, the breaker for 110?


I have not as I am not currently at the unit. Gathering info as to what to do/look for when I am back to the unit.
__________________
2016 CR Z1 32 bhs
smoke33 is offline   Reply With Quote
Old 09-22-2019, 07:49 AM   #6
Family Vacation Member
 
Join Date: Jun 2018
Location: Mb
Posts: 150
Quote:
Originally Posted by smoke33 View Post
I have not as I am not currently at the unit. Gathering info as to what to do/look for when I am back to the unit.


__________________
2013 Zinger ZT260BH towed by a 2013 Silverado Z71 1500 CC 5.3L
660catman is online now   Reply With Quote
Old 09-22-2019, 08:24 AM   #7
Full Time Camper
 
harley's Avatar
 
Join Date: Aug 2012
Location: Belle River , Ontario
Posts: 1,656
Catman is correct .sparking is from 12v battery . Nothing to do with 110v electric.
__________________


It was a rainy few days at Algonquin Prov park...tarps kept us dry.
Wayne --Belle River (Windsor), Ontario
2013 Sunset Trail Reserve 25RB..
2015 White Chev Silverado 2500HD 4x4 (6.0 l gasser)
2003 Mountain Star 890SBRX Truck Camper
harley is offline   Reply With Quote
Old 09-22-2019, 08:36 AM   #8
Family Vacation Member
 
Join Date: Jun 2018
Location: Mb
Posts: 150
Double check your GFCI plug inside your camper too. This summer my outside plug didnít work. After checking plug on kitchen wall I finally figured out it shared the bathroom circuit which that GFCI was tripped. You never know!
__________________
2013 Zinger ZT260BH towed by a 2013 Silverado Z71 1500 CC 5.3L
660catman is online now   Reply With Quote
Old 09-22-2019, 09:06 AM   #9
Weekend Camper
 
Join Date: Mar 2018
Location: Illinois
Posts: 55
My wife is out at the camper along with My brother in-law. I had them take off the panel. The unit was never even plugged into the outlet from when it was put together at Crossroads!!! All is working now.
Here is where I am extremely miffed and didnít give previous details on. Because Crossroads did not plug in the unit all meet in freezer and food in fridge rotted and leaked all inside the cracks and crevices. On top of that we got maggots all on the inside. My wife has cleaned inside multiple times but the smell is still bad. After cleaning the maggots out, as the unit cooled more appeared from Iím assuming the cracks and crevices.
I am afraid if the smell doesnít go away we may have to replace the unit because of a manufacturer mistake.

How hard is the unit to remove in order for me to try and clean the sides, back etc.?

Thanks for all the trouble shooting replies!!
__________________
2016 CR Z1 32 bhs
smoke33 is offline   Reply With Quote
Old 09-22-2019, 09:23 AM   #10
Family Vacation Member
 
Join Date: Jun 2018
Location: Mb
Posts: 150
I personally ave never changed one so I canít tell you. I wouldnít think it would be that hard though.
__________________
2013 Zinger ZT260BH towed by a 2013 Silverado Z71 1500 CC 5.3L
660catman is online now   Reply With Quote
Old 09-22-2019, 09:47 AM   #11
Full Time Camper
 
travelin texans's Avatar
 
Join Date: Feb 2016
Location: Texas
Posts: 1,106
If bought new the blame is on your dealer, & you! Your dealer is paid to do an inspection once it arrives at the dealership. They should've had the fridge running & cooled down the day you took delivery when you did your PDI.
__________________
Danny & Linda
Sold my '13 Redwood 36FB
Currently rv & truckless
travelin texans is offline   Reply With Quote
Old 09-22-2019, 09:53 AM   #12
Weekend Camper
 
Join Date: Mar 2018
Location: Illinois
Posts: 55
Domestic Freezer/Fridge Issues

Quote:
Originally Posted by travelin texans View Post
If bought new the blame is on your dealer, & you! Your dealer is paid to do an inspection once it arrives at the dealership. They should've had the fridge running & cooled down the day you took delivery when you did your PDI.


If the propane was on which it was, the fridge would have been and was working.
So the blame still remains with the manufacturer.
__________________
2016 CR Z1 32 bhs
smoke33 is offline   Reply With Quote
Old 09-22-2019, 03:19 PM   #13
Weekend Camper
 
Join Date: Mar 2018
Location: Illinois
Posts: 55
No ideas to get the smell out or how to take the unit out?
__________________
2016 CR Z1 32 bhs
smoke33 is offline   Reply With Quote
Old 09-22-2019, 03:39 PM   #14
Family Vacation Member
 
Join Date: Jun 2018
Location: Mb
Posts: 150
I have a Norcold which has a black bezel around the from. Looks like itís screwed on in 4 places. I think once you figure out bezel removal it would be straight forward on whatís needed to remove fridge. As far as cleaning, a bleach solution should help.
__________________
2013 Zinger ZT260BH towed by a 2013 Silverado Z71 1500 CC 5.3L
660catman is online now   Reply With Quote
Old 09-22-2019, 03:52 PM   #15
Weekend Camper
 
Join Date: Mar 2018
Location: Illinois
Posts: 55
Quote:
Originally Posted by 660catman View Post
I have a Norcold which has a black bezel around the from. Looks like itís screwed on in 4 places. I think once you figure out bezel removal it would be straight forward on whatís needed to remove fridge. As far as cleaning, a bleach solution should help.


Thank you
__________________
2016 CR Z1 32 bhs
smoke33 is offline   Reply With Quote
Old 09-29-2019, 04:05 PM   #16
New Camper
 
Join Date: Oct 2016
Location: Il
Posts: 8
There is a you tube video on the step by step instructions to take it out. I had to trash the one that we had and bought a residential one instead
Keithdodge2001 is offline   Reply With Quote
Old 09-29-2019, 04:55 PM   #17
New Camper
 
Join Date: Mar 2012
Location: Ontario
Posts: 3
There is probably no juice going to your fridge try plugging a lamp to see if it works. I just had the same problem. My gfi plug in the trailer had jumped so just reset it
gaslou is offline   Reply With Quote
Old 09-29-2019, 04:57 PM   #18
Weekend Camper
 
Join Date: Mar 2018
Location: Illinois
Posts: 55
Quote:
Originally Posted by gaslou View Post
There is probably no juice going to your fridge try plugging a lamp to see if it works. I just had the same problem. My gfi plug in the trailer had jumped so just reset it


See post #9
__________________
2016 CR Z1 32 bhs
smoke33 is offline   Reply With Quote
Old 09-29-2019, 05:38 PM   #19
Site Team
 
Join Date: Jun 2015
Location: mo
Posts: 721
Just a few thoughts. Open it up and let it air out then wash thoroughly with a bleach solution then rinse with water then wash with a baking soda and water solution dry thoroughly then close it up with a few boxes of baking soda poured in a pan . Also charcoal works good to help remove odors. Should help some. We had a freezer that somehow got unplugged and thats what we did. It may take more than one application.
__________________
2005 Cruiser 29CK
2008 GMC 2500hd 4x4
Crew cab Long bed 6.0 gas
4.10 gear ratio
dagst1 is offline   Reply With Quote
Old 09-30-2019, 12:25 PM   #20
New Camper
 
dtseahag's Avatar
 
Join Date: Feb 2017
Location: NC
Posts: 7
My power went out a few months ago and then gas ran out. Had soft shell crabs in it. The smell was awful. Tried on the tricks in the book to get smell out. Was close to just replacing it when ServPro Fire and Water Restoration rep loaned me an O-zone machine. Had to run it for about 4 hours with no one or pets in camper. It was amazing. The smell was gone. Good luck.
__________________
Mary Ann
dtseahag is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 07:31 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×