Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-10-2015, 02:10 PM   #1
New Camper
 
Join Date: May 2015
Location: Iowa
Posts: 1
Electric plug problems

2011 cross road Zinger the side of the slide out the electric plug plus the two plugs by the front and the plugs in the front bed room and the one under the sink has all stopped working.

Electric plug in bathroom, and back room are working

I checked the breakers, 120 v out of all of them. plus checked all the fuses with
13 Dc coming out of all of them.

Does any one know if they are on a system like Christmas Lights and if one electric plug goes bad they all go out ?

Rick

RickB is offline   Reply With Quote
Old 05-10-2015, 02:14 PM   #2
Full Time Camper
 
gball's Avatar
 
Join Date: Feb 2006
Location: Texas
Posts: 526
Sounds like you have a GFI breaker tripped. Check all of your GFI outlets for a tripped breaker.
__________________
George & Lynda
College Station, TX
2011 Cruiser CF335SS Patriot
'04 Dodge 2500 Quadcab CTD
gball is offline   Reply With Quote
Old 05-10-2015, 03:15 PM   #3
Full Time Camper
 
Join Date: Oct 2004
Location: Texas
Posts: 1,508
George is right, there are typically just 2 GFI outlets and all other outlets in the RV are wired to one of them. If one of them trips, you will loose many outlets. Also, the GFI may have failed due to a bad connection that caused the GFI to overheat. I had this happen earlier this year. Even if you aren't qualified to fix an electrical problem, you can remove the cover plate and use a flashlight to check for discolored plastic and/or melted wire insulation. With shore power removed, you can safely loosen the top and bottom screws on the outlet for better inspection.
__________________
Larry Day

Texas Baptist Men-Retiree Builders member since '01
13 Silverado 3500HD D/A, 2wd CCSB srw, custom RKI bed
11 Cruiser CF32MK
http://www.picturetrail.com/dayle1
Dayle1 is offline   Reply With Quote
Old 05-10-2015, 04:40 PM   #4
Full Time Camper
 
Tim D's Avatar
 
Join Date: May 2013
Location: So IL
Posts: 1,811
x3...Not that hard to replace if needed.
__________________

Tim
13 ST25RB
08 F-250 SC 6.8L XLT 4x4
Tim D is offline   Reply With Quote
Old 05-10-2015, 08:35 PM   #5
Full Time Camper
 
Stan's Avatar
 
Join Date: Apr 2006
Location: Oak Harbor, WA
Posts: 1,978
I agree it sounds like a GFI has tripped. I believe your second one is in the kitchen area. If it trips again, check for water intrusion in one of the 2 or 3 junction boxes (grey plastic) located under the slide outs.
__________________
Stan and Terri
Oak Harbor, WA
2008 Chevy 2500HD D/A
2007 Cruiser CF30SK
Glide Ride Pin Box
Reese 16K Slider
Stan is offline   Reply With Quote
Old 05-11-2015, 07:03 AM   #6
Full Time Camper
 
OhioMark's Avatar
 
Join Date: Mar 2013
Location: United states of america
Posts: 1,529
X3,

I had the same issue and it was a short in the slide, so the GFIs "stayed" tripped.
__________________

2017 Ford F350 Super Duty 6.7 King Ranch Crew
2016 Crossroads Sunset Trail Grand Reserve 32BH
OhioMark is offline   Reply With Quote
Old 05-16-2015, 11:09 AM   #7
Seasonal Camper
 
Join Date: Feb 2005
Location: Mid-Missouri
Posts: 449
We had an issue on our sofa side slide shortly after getting our fiver. Couldn't reset the GFI. Turned out there was an electrical box under the slide used to splice the wires. It was not sealed adequately and got water in it while driving in the rain. Dried it out, resealed and no issues since.
__________________
2016 Duramax - 2010 CF30SKP

Viet Nam Vet 70-71 Da Nang

Real airplanes have two wings and big, round, engines
BipeFlier is offline   Reply With Quote
Old 05-18-2015, 02:41 PM   #8
Weekend Camper
 
ConveyTrex's Avatar
 
Join Date: Nov 2014
Location: Massachusetts
Posts: 24
Dirty power from a non-inverter generator can permanently bugger some GFI outlets too, I had one flake out on my old Viking pup after using my Champion 4k generator and had to change it with a new one..
__________________

Matt & Kirsten - Seekonk, Massachusetts
2015 Z-1 252TD Toy Hauler
2002 AVALANCHE 2500 8.1L Z85
ConveyTrex is offline   Reply With Quote
Old 05-18-2015, 05:59 PM   #9
Full Time Camper
 
cowboy_71's Avatar
 
Join Date: Oct 2009
Location: LA
Posts: 948
We have two GFI outlets, one in kitchen one in bathroom. Check all the outlets, we were surprised by the one in kitchen in our old camper, didn't know we had it till outlets stopped working?...
__________________
07 Cruiser 30sk

06 F350 KR PS CC SRW

...Wish we were camping...
cowboy_71 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 08:10 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.