Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-11-2020, 08:38 PM   #1
Weekend Camper
 
Join Date: Dec 2017
Location: WV
Posts: 14
electrical outlet

Over Christmas my outlet in the kitchen slideout went out and same time the refrigerator stopped operating on electricity. I switched to propane and I am puzzled. I have checked fuse box, reset power outlets and nothing. Is there a reset switch for the refrigerator and or slideout that I am not finding. They have to be connected both the outlet and the refrigerator went out the same time. The refrigerator is not plugged into the outlet but they are both in the slideout.
cdessy99 is offline   Reply With Quote
Old 01-11-2020, 09:04 PM   #2
Site Team
 
Join Date: Jun 2015
Location: mo
Posts: 754
Have you checked the GFCI outlet. It may have tripped.. Also you may need to check the junction box under the slide. They have been known to get water in them or have a loose connection.
__________________
2005 Cruiser 29CK
2008 GMC 2500hd 4x4
Crew cab Long bed 6.0 gas
4.10 gear ratio
dagst1 is offline   Reply With Quote
Old 01-17-2020, 10:42 PM   #3
Full Time Camper
 
Join Date: Apr 2011
Location: Pennsylvania
Posts: 2,409
Quote:
Originally Posted by dagst1 View Post
Have you checked the GFCI outlet. It may have tripped.. Also you may need to check the junction box under the slide. They have been known to get water in them or have a loose connection.
cdessy
You might also want to attach a signature with the make and model of your camper with your posts...That way when you ask a question members that have the same model would have a better idea how to help you...Also dagst1 answer is spot on...
__________________
Rosie & Tommy
Coatesville Pa.
2017 Ford F350 Lariat Power Stoke DW
2013 Cruiser Patriot 305 SKP

In God We Trust
A proud member of the one percent...Semper Fi
sleepyT is offline   Reply With Quote
Old 01-19-2020, 03:46 PM   #4
New Camper
 
Join Date: Jul 2018
Location: Quebec
Posts: 3
I had the same problem last summer. The GFI under the kitchen cabinet was defect. I replaced it and that fixed the problem.
__________________
2013 CF27 RKX
Cowansville Qc.
Canada
dostiem is offline   Reply With Quote
Old 01-19-2020, 03:54 PM   #5
Weekend Camper
 
Nigel's Avatar
 
Join Date: Jan 2019
Location: TX
Posts: 29
Quote:
Originally Posted by dagst1 View Post
Have you checked the GFCI outlet. It may have tripped.. Also you may need to check the junction box under the slide. They have been known to get water in them or have a loose connection.
Check the shore power. I was staying at a State Park one time and had no outlet power. I spent 1/2 a day checking circuits, breakers, GFCI's etc, all were good. Come to find out it was a bad connector at the electrical plug in from the State park
__________________
2015 Crossroads Cruiser 305RS
2012 Ford F250 6.7 Diesel
<---- My other RV is a Vans Aircraft RV9A
Nigel is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 01:43 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×