Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-16-2013, 04:45 AM   #1
New Camper
 
Join Date: May 2012
Location: Tx
Posts: 5
I have a 2012 with a thermaheat electric fireplace. It quit working altogether. I am just over the warranty I believe but don't want to have to purchase another new. I have contacted Lasalle Bristol who makes the fireplace but they aren't much help. What are my options?

Any advise would be appreciated!
Rattlesnake is offline   Reply With Quote
Old 07-16-2013, 05:29 AM   #2
Full Time Camper
 
Hunter11's Avatar
 
Join Date: Oct 2004
Location: Central Texas
Posts: 2,510
I am sure you have checked the breaker it is on so is there any chance there could be a fuse or a reset button on the back of the unit?
__________________
17 Chevy 3500 DRW 4X4
16 Mobile Suites 36RSSB4
2 Mini Dachshunds
Hunter11 is offline   Reply With Quote
Old 07-16-2013, 09:19 AM   #3
Full Time Camper
 
Join Date: Sep 2007
Location:
Posts: 1,415


Also check where the wires go inside the fireplace. They have been finding loose contacts there. Always check every thing the factory does from breaker box to the outlite.
cwit is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 01:10 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×