Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-10-2012, 06:46 AM   #1
Weekend Camper
 
Bill Jenner's Avatar
 
Join Date: Apr 2011
Location: Wmsburg, VA
Posts: 12




I am on my maiden voyage with a new Cruiser with a model DM2852 refrigthat seemingly tries to cycle through a process I am not use to. My last unit was a 2002.. This newer one wants to HUMMM about every hour or soand I've never known a refrig/freezerto do that..Has anyone else noticed this or do I need to get her into a repair shop when I get home.?? It sounds electrical to me..Any ideas out there.?

Williamsburg, VA
__________________
Bill
Bill Jenner is offline   Reply With Quote
Old 02-10-2012, 07:46 AM   #2
Full Time Camper
 
gball's Avatar
 
Join Date: Feb 2006
Location: Texas
Posts: 526
If you can hear the noise when outside the unit it is probably the fan that is installed at the back of the refrigerator to cool the coils when they get over a certain temperature. The one on our 335SS is really noisy. Randy at CrossRoads had Dometic send me a new fan and it is worse than the one originally installed when the unit was built. I think that Dometic got a bad batch of fans. It is my opinion that there should not be any noise when the fan is operating. I suggest that you have the dealer take a look at it.
__________________
George & Lynda
College Station, TX
2011 Cruiser CF335SS Patriot
'04 Dodge 2500 Quadcab CTD
gball is offline   Reply With Quote
Old 02-17-2012, 11:34 AM   #3
Weekend Camper
 
Bill Jenner's Avatar
 
Join Date: Apr 2011
Location: Wmsburg, VA
Posts: 12




Concur on the fan George.. Dometic tells me to get it in to an authorized shop for a check-up, and you know how that goes.. Can't dup the problem.! All we are talking about is a $10.00 fan with a bad temp sensor or too much vibration.!Radio Shack has totally quiet computer fans, not a $60.00 model from Dometic, but then I'm still in warranty so its off to the shop when I get home..Thanks for the feedback.
Bill
__________________
Bill
Bill Jenner is offline   Reply With Quote
Old 02-17-2012, 12:01 PM   #4
Full Time Camper
 
Stan's Avatar
 
Join Date: Apr 2006
Location: Oak Harbor, WA
Posts: 1,994
If it turns out to be the fan, Mine never came on even in over 100 temps. I removed the thermo-sensor and wired in an on/off switch. Now I turn it on whenever the temps get to about 80+.



__________________
Stan and Terri
Oak Harbor, WA
2008 Chevy 2500HD D/A
2007 Cruiser CF30SK
Glide Ride Pin Box
Reese 16K Slider
Stan is offline   Reply With Quote
Old 02-17-2012, 12:09 PM   #5
Seasonal Camper
 
Sirsea's Avatar
 
Join Date: Feb 2011
Location: League City, TX
Posts: 265
Appears to be a problem with quite a few new units. Ours has been in the shop since October, had the fan replaced twice and still making a humming, buzzing noise. Dometic hasn't a clue to what's wrong, tried new mounting insulation, screws, ets. Talked with CR today and trying to get them to replace the frig with a Norcold. At least 10 other owners I know of are having the same problem. I suggest you contact your dealer and CR.
Sirsea is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 04:59 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×