Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-08-2016, 11:32 AM   #1
Weekend Camper
 
Join Date: Aug 2015
Location: Il
Posts: 18
Furnace

I have a 2015 sunset trail. Took it back to dealership / they said bled air out of lines. & that it was fine. I brought it back 1 and a half hour drive. I turned the furnace on & it just has blower on. It does not even try to ignite. Any suggestions. I called dealership Saturday & have not heard back.
C.nack72 is offline   Reply With Quote
Old 05-08-2016, 11:50 AM   #2
Full Time Camper
 
Papa-T's Avatar
 
Join Date: May 2012
Location: N.C. Mountains
Posts: 1,486
Is there another dealership near you that will do warranty work?
__________________
*2016 CAF25SE Cruiser Aire 5er/*Joined 2010 *Changed Username and lost Post #'s -2012.
*Traded Campers and Left Crossroads -2012.
*Purchased New 5er & Came back May-2016
*Ted & Tricia (Mimi and Boo - Poodles)
I have tried to live my life so that my family would love me and my friends would respect me. The others can do whatever the Hell they please!” —John Wayne
Papa-T is offline   Reply With Quote
Old 05-08-2016, 12:23 PM   #3
Weekend Camper
 
Join Date: Aug 2015
Location: Il
Posts: 18
No there is not
__________________
2015 sunset trail
C.nack72 is offline   Reply With Quote
Old 05-08-2016, 05:50 PM   #4
Full Time Camper
 
woodwalker's Avatar
 
Join Date: Oct 2015
Location: ca
Posts: 526
Try turning your stove burners on and after they are running try the furnace. This is the best way to get air out of the lines. Furnace or hot water heater will not light with any air in the lines. You should also be able to here either on clicking trying to light. I believe they will click 3 times trying to ignite
__________________
2015 Redwood 36RL pushing a 2015 Denali DRW
woodwalker is offline   Reply With Quote
Old 05-08-2016, 07:15 PM   #5
Full Time Camper
 
Steve7's Avatar
 
Join Date: Sep 2015
Location: Nv
Posts: 624
I have to do the same thing sometimes to get the fridge to light. Lighting the stove for a minute or so does the trick for me.
__________________
Steve & Sue
2017 Grand Design 297RSTS Travel Trailer
2017 Ford F-350 Lariat Crew Cab diesel 6.7 SW LB 11,500 lb GVWR package
Former: Crossroads ST26RB
Steve7 is offline   Reply With Quote
Old 05-09-2016, 02:21 AM   #6
Weekend Camper
 
Join Date: Aug 2015
Location: Il
Posts: 18
I am thinking the sail switch or the motherboard is bad I here no clicking
__________________
2015 sunset trail
C.nack72 is offline   Reply With Quote
Old 05-09-2016, 02:23 AM   #7
Weekend Camper
 
Join Date: Aug 2015
Location: Il
Posts: 18
Two I have done all that thinking it's something like a switch or board
__________________
2015 sunset trail
C.nack72 is offline   Reply With Quote
Old 05-09-2016, 10:23 AM   #8
Family Vacation Member
 
Join Date: Apr 2015
Location: S. Illinois (means South of I-80)
Posts: 112
Check to make sure something didn't make a nest in the exhaust.
__________________
2015 Sunset Trail 270bh
2011 Ford f150 Eco Beast 3.73-max tow-max payload, man mirrors

Screen Name = half Labrador, half Beagle and full of attitude.
Labbie is offline   Reply With Quote
Old 05-09-2016, 01:01 PM   #9
Weekend Camper
 
Join Date: Sep 2015
Location: ontario
Posts: 66
I had the same issue the furnace would not light. It was the limit switch had tripped do to poor air flow. it would not reset it self. I pulled the furnace out and the so called duct work which is made out off card board. I took it to our fab shop and made a new duct plenum, out of real metal. Lots of air flow now out of all 4 ducts.
vacationer is offline   Reply With Quote
Old 05-10-2016, 01:35 AM   #10
Weekend Camper
 
Join Date: Nov 2015
Location: Pennsylvania
Posts: 65
My issue might have been different as mine was doing the try to ignite three times and failing before shutting down, but it must have reset itself when I disconnected the battery while winterized. Worked fine and still does, touch wood, next time we hooked everything up.
__________________
Scott & Phyllis
2016 Crossroads Sunset Trail 250RB
2015 Ford F150 Supercrew/3.5 Ecoboost/Max Tow
blkdth1313 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 08:48 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.