Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-13-2018, 05:26 PM   #1
Weekend Camper
 
Join Date: Nov 2018
Location: TN
Posts: 11
Furnace heater not igniting

Just bought a 2007 crossroads cruiser and furnace isn't working. Started out good and was sparking well, but now I dont even here the spark when I crank thermostat. Any help please?
Red7414 is offline   Reply With Quote
Old 11-13-2018, 05:31 PM   #2
Full Time Camper
 
harley's Avatar
 
Join Date: Aug 2012
Location: Belle River , Ontario
Posts: 1,559
Have you recently switched tanks? If so ,shut all tanks. Open stove valves, shut valves, reopen one tank slowly. Start stove burners for a bit. Then try furnace.
__________________


It was a rainy few days at Algonquin Prov park...tarps kept us dry.
Wayne --Belle River (Windsor), Ontario
2013 Sunset Trail Reserve 25RB..
2015 White Chev Silverado 2500HD 4x4 (6.0 l gasser)
2003 Mountain Star 890SBRX Truck Camper
harley is offline   Reply With Quote
Old 11-13-2018, 08:11 PM   #3
Seasonal Camper
 
2slick's Avatar
 
Join Date: Sep 2012
Location: Rockport, TX
Posts: 396
Blower should run before ignition. Check your 12 VDC fuse.
__________________
Will

2013 Chevy 3500HD
2012 Rushmore 38CK
2slick is offline   Reply With Quote
Old 11-14-2018, 10:43 AM   #4
Weekend Camper
 
Join Date: Nov 2018
Location: TN
Posts: 11
Harley I did what you said but when I furnace the thermostat to on, there wasnt any clicking as if the spark isn't igniting. Makes a ticking noise but it's not the spark that I'm accustomed to hearing.
Red7414 is offline   Reply With Quote
Old 11-14-2018, 11:09 AM   #5
Site Team
 
Join Date: Jun 2015
Location: mo
Posts: 269
Could the furnace be in "lockout mode"? I just replaced the thermostat in my camper and I had already turned the gas off for winter so when trying the new thermostat it would not start and when I realized the gas was off it was in lockout mode. I turned off the breaker to the camper power post and had already removed the battery so I had no power then waited about 3 or 4 minutes turned the power back on and Tried the furnace and it started. Don't know if this it what you have wrong but its something to check.
__________________
2005 Cruiser 29CK
2008 GMC 2500hd 4x4
Crew cab Long bed 6.0 gas
4.10 gear ratio
dagst1 is offline   Reply With Quote
Old 11-14-2018, 11:14 AM   #6
Weekend Camper
 
Join Date: Nov 2018
Location: TN
Posts: 11
I will try that now, also just noticed the pilot light is lit at the base of tube but isn't pushing heat out. If it was in lockout mode, would the burners on stove still work, be a so they are at the moment
Red7414 is offline   Reply With Quote
Old 11-14-2018, 11:44 AM   #7
Site Team
 
Join Date: Jun 2015
Location: mo
Posts: 269
Kind of confused. Your furnace has a pilot light? And the stove lighting just means that you have gas available. Your furnace should be "spark ignition" and would not have a pilot light. You have a 2007 so the only thing that may have a pilot light would be the oven and stove top. My 05 Cruiser has a pilot light on the oven but that's it. The furnace is DSI -Direct Spark Ignition any you can not see the burner.
__________________
2005 Cruiser 29CK
2008 GMC 2500hd 4x4
Crew cab Long bed 6.0 gas
4.10 gear ratio
dagst1 is offline   Reply With Quote
Old 11-14-2018, 11:56 AM   #8
Weekend Camper
 
Join Date: Nov 2018
Location: TN
Posts: 11
I just meant I can see the tube that runs up from the furnace on the outside holding area. It was lit out there a few moments ago and now it's not. I turned off power and turned back on and still nothing. I can hear the sparking down low but it seems it's not catching? And sorry but I'm just as confused and this is my first camper. Hope I'm giving enough detail.
Red7414 is offline   Reply With Quote
Old 11-14-2018, 12:16 PM   #9
Site Team
 
Join Date: Jun 2015
Location: mo
Posts: 269
What is the model of your camper? I have a Cruiser also and it is a 29ck. This may help me research your problem.
__________________
2005 Cruiser 29CK
2008 GMC 2500hd 4x4
Crew cab Long bed 6.0 gas
4.10 gear ratio
dagst1 is offline   Reply With Quote
Old 11-14-2018, 12:34 PM   #10
Weekend Camper
 
Join Date: Nov 2018
Location: TN
Posts: 11
2007 crossroads cruiser 30 sk
Red7414 is offline   Reply With Quote
Reply

Tags
furnce, not sparking

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 05:25 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.