Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-23-2013, 12:00 AM   #1
Seasonal Camper
 
Join Date: Mar 2007
Location: Ohio
Posts: 388
I was sanitizing water system this morning and after having run water through the "hot side" several times all of a sudden when I opened a hot tap... nothing came out! It had been fine and then all of a sudden nothing. I checked all the hot water taps and it was the same, no water. Cold side is fine. I went to the water heater and switched the valves to "bypass" and the hot water would flow again although it was obviously not going through the hot water tank. I am thinking it must be the check valve went bad. Any ideas?
Thanks,
Lonnie
__________________
07 Cruiser 29BT

04 2500 Hemi Ram Quad Cab
Chuck N. Wined is offline   Reply With Quote
Old 06-23-2013, 12:21 AM   #2
Weekend Camper
 
camperjim's Avatar
 
Join Date: Jan 2013
Location: Leetonia Oh
Posts: 97


Lonnie are you sanitizing your system using the on board fresh water tank or city water? Jim
__________________
love camping 15 f350 12 rushmore
camperjim is offline   Reply With Quote
Old 06-23-2013, 02:15 AM   #3
Seasonal Camper
 
Join Date: Mar 2007
Location: Ohio
Posts: 388
Freshwater tank.
__________________
07 Cruiser 29BT

04 2500 Hemi Ram Quad Cab
Chuck N. Wined is offline   Reply With Quote
Old 06-23-2013, 02:59 AM   #4
Weekend Camper
 
camperjim's Avatar
 
Join Date: Jan 2013
Location: Leetonia Oh
Posts: 97


the only check valve that I know about is in the pump so that when you hook up to city water the pressure from the city side does not hurt the pump did you try and hook up to city water and see if that works the hot water Jim
__________________
love camping 15 f350 12 rushmore
camperjim is offline   Reply With Quote
Old 06-23-2013, 03:16 AM   #5
Full Time Camper
 
anaro's Avatar
 
Join Date: Jan 2011
Location: Mebane, NC
Posts: 2,394
is it filling your hot water tank first?
__________________

2014 Chevy Silverado 3500 SRW Duramax
2011 Zinger ZT26BL-sold
2014 Sabre 34REQS

***Member of the Mason-Dixon Group***
anaro is offline   Reply With Quote
Old 06-23-2013, 03:26 AM   #6
Weekend Camper
 
tabrown2001's Avatar
 
Join Date: Mar 2012
Location: Kentucky
Posts: 33
I think anaro might have it. It may be pumping 6 or 10 gallons into the hot water tank to fill it up first. It does take some time assuming I understood anaro's comment correctly. Are you getting any air or pressure at all on the hot side?

__________________
2003 Ford F350 Dually

2010 Zinger 31SB
tabrown2001 is offline   Reply With Quote
Old 06-23-2013, 09:53 AM   #7
Family Vacation Member
 
Join Date: Jan 2009
Posts: 144


There is a check valve on most hot water outlets! It will be a brass fitting rightat the outlet opening. Check this once you determine the tank is full!
carl is offline   Reply With Quote
Old 06-23-2013, 12:36 PM   #8
Seasonal Camper
 
Join Date: Mar 2007
Location: Ohio
Posts: 388
Thanks for the input. Carl wins!!! The issue is the check valve! It is a the top of the water heater and was a bear to get out! I have easy access but is was stuck in there. Now I just have to find one before we leave on vacation in 2 days! I will start checking locally in the morning.
Lonnie
__________________
07 Cruiser 29BT

04 2500 Hemi Ram Quad Cab
Chuck N. Wined is offline   Reply With Quote
Old 06-23-2013, 02:35 PM   #9
Full Time Camper
 
Join Date: Nov 2006
Location: Bradley, Il
Posts: 1,018


Lonnie, had two check valves fail on my '07. Finally just replaced it with a valve. No more problems.
__________________
Dale & Carol
Bradley, Il
2007 F-250
2010 CF30SK Patriot
2007 CF30SK
dalemac377 is offline   Reply With Quote
Old 06-23-2013, 04:06 PM   #10
Full Time Camper
 
anaro's Avatar
 
Join Date: Jan 2011
Location: Mebane, NC
Posts: 2,394
Glad o hear you found the problem.
__________________

2014 Chevy Silverado 3500 SRW Duramax
2011 Zinger ZT26BL-sold
2014 Sabre 34REQS

***Member of the Mason-Dixon Group***
anaro is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 06:47 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×