Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-15-2015, 07:43 AM   #1
Full Time Camper
 
Tim D's Avatar
 
Join Date: May 2013
Location: So IL
Posts: 1,811
LP / CO Detector

My CO alarm went off shortly after backing it into driveway. I thought maybe due to having door open and truck running. I have vented the camper and tried to reset it several times. I did some research which wasn't very helpful. I did see a statement that said they had a fuel cell inside which is usually used up approx 2 yrs from manufacture. Anyone else have this issue? It is hardwired to 12 volt and has power.
__________________

Tim
13 ST25RB
08 F-250 SC 6.8L XLT 4x4
Tim D is offline   Reply With Quote
Old 06-15-2015, 11:38 AM   #2
Site Team
 
Join Date: Dec 2007
Location: WI.
Posts: 7,251
This happened to me on our Lance truck camper. Had to replace it. They weren't cheap then. and I can only imagine how much they have went up in price.
__________________
08 CF26RK
2013 Ford Eco-Boost
Heavy duty payload - Max tow
Lloyd is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 08:55 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.