Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-04-2018, 08:05 AM   #1
Weekend Camper
 
Join Date: Aug 2017
Location: Pa
Posts: 22
propane water heater question

Hoping someone can help us out. We have an Atwood water heater. The electric side works great, however, when we try and use it on propane, we don't get any ignition even trying to start. It makes a humming sound but there is no spark even trying to light. Any thoughts on what to check? It worked when we opened the unit up for the first time this spring but now will not even attempt to light. We have tried lighting the stove first to make sure the gas it back to the heater. Any suggestions would be appreciated Thank you
__________________
2016 Crossroads Z-1 225 RB
Judyg is offline   Reply With Quote
Old 06-04-2018, 09:59 AM   #2
Full Time Camper
 
Steve7's Avatar
 
Join Date: Sep 2015
Location: Nv
Posts: 589
Quote:
Originally Posted by Judyg View Post
Hoping someone can help us out. We have an Atwood water heater. The electric side works great, however, when we try and use it on propane, we don't get any ignition even trying to start. It makes a humming sound but there is no spark even trying to light. Any thoughts on what to check? It worked when we opened the unit up for the first time this spring but now will not even attempt to light. We have tried lighting the stove first to make sure the gas it back to the heater. Any suggestions would be appreciated Thank you
Look in the gas flue pipe where the flame comes from normally, and see if there are any obstructions, such as bugs.
__________________
Steve & Sue
2017 Grand Design 297RSTS Travel Trailer
2017 Ford F-350 Lariat Crew Cab diesel 6.7 SW LB 11,500 lb GVWR package
Former: Crossroads ST26RB
Steve7 is offline   Reply With Quote
Old 06-04-2018, 11:03 AM   #3
Weekend Camper
 
Join Date: Aug 2017
Location: Pa
Posts: 22
Everything looks clear, however, it does act like it isn't getting any propane back to it!
__________________
2016 Crossroads Z-1 225 RB
Judyg is offline   Reply With Quote
Old 06-04-2018, 11:23 AM   #4
Full Time Camper
 
travelin texans's Avatar
 
Join Date: Feb 2016
Location: Texas
Posts: 1,020
Your battery is fully charged? The water heater ignition & propane controls require a full 12 volts.
__________________

Danny & Linda
Fulltimers since '08
2013 Redwood 36FB (FOR SALE)
2013 GMC Denali DRW
travelin texans is offline   Reply With Quote
Old 06-04-2018, 03:09 PM   #5
Full Time Camper
 
Russb's Avatar
 
Join Date: Oct 2009
Location: Texas
Posts: 559
Quote:
Originally Posted by Judyg View Post
Everything looks clear, however, it does act like it isn't getting any propane back to it!
Trouble shooting guide may help. Check the 12v connections that would open the gas valve.

Atwood Water Heater Troubleshooting
__________________
Russ
Forney,TX
2010 Cruiser CTX CT29RLX
2009 F-150XLT
Russb is offline   Reply With Quote
Old 06-04-2018, 09:10 PM   #6
Weekend Camper
 
Join Date: Aug 2017
Location: Pa
Posts: 22
Yes, the battery is full charge.
__________________
2016 Crossroads Z-1 225 RB
Judyg is offline   Reply With Quote
Old 06-10-2018, 03:55 PM   #7
New Camper
 
Join Date: Jun 2014
Location: Ontario
Posts: 2
Can you smell the propane? I find anytime I haven’t used the propane in the trailer for a while it takes a bit to purge the lines. Try turning on your stove on and lighting it for a bit to purge the lines and then turn on your hot water tank. I have to do this to use my fridge on propane sometimes.
Couckiemonster is offline   Reply With Quote
Old 06-10-2018, 07:52 PM   #8
Weekend Camper
 
Join Date: Aug 2017
Location: Pa
Posts: 22
No we can not smell any propane. We have purged the lines and lit the stove as you suggested and still no luck.
__________________
2016 Crossroads Z-1 225 RB
Judyg is offline   Reply With Quote
Old 06-11-2018, 04:40 AM   #9
Seasonal Camper
 
Join Date: Mar 2014
Location: MA
Posts: 250
Time for a new card or board.
__________________
Retired U.S. Navy Engineer

2016 Ram 2500 Bighorn 5.7 Hemi
2014 Zinger 27RL
2004 Tracker 175 Bass boat
markandkim is offline   Reply With Quote
Old 06-11-2018, 06:45 AM   #10
Full Time Camper
 
fhenn's Avatar
 
Join Date: Jul 2006
Location: Ms
Posts: 2,728
Did you check for a mud dopper nest in the tube
__________________
Frank and Janet Henn
2017 380MBH pushing a 2007 Dodge
CDT with a six speed Automatic
Traveling with Hoover and Rainbow the wonder dogs and now with Sunshine the rescue Schnauzer.
fhenn is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 12:11 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.