Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-04-2010, 02:26 AM   #1
New Camper
 
Join Date: May 2009
Location: Calgary, AB
Posts: 4
The kitchen sideout in my2009 Cruiser 30SK just stopped working. It worked fine in the morning when we packed up, but when we had parked in the driveway to clean it out the sideout would not move -it was just dead with no power. The other 2 sideouts worked just fine. I checked everything I could think of including the breakers & fuses with no luck. I'm now thinking broken wire, faulty switch, burned out relay or perhaps motor. Any suggestions of where to start looking would be helpful? I know that it is still under warranty but if it is something simple, I would prefer to try and do it myself rather than taking it into my dealer - its about 1.5 hrs. each way.



Cheers!



KJPCalgary1
KJPCalgary1 is offline   Reply With Quote
Old 08-04-2010, 03:53 AM   #2
Family Vacation Member
 
Join Date: Jan 2009
Location:
Posts: 194
First thing I would do is check to see if there is voltage present at the motor. Take volt meter and measure at the input of the motor assembly while someone is depressing the rocker switch.

If 12 volts present then it's a motor issue. If not you will have to start working backwards toward the switch. Check switch same way.

One thing you might try is just manually open the slide a few inches and then try the motor. Doubt this will make any difference but would be easy.

good luck.


pulpwood007 is offline   Reply With Quote
Old 08-04-2010, 03:57 PM   #3
Family Vacation Member
 
SWAILES's Avatar
 
Join Date: Jul 2010
Location: Ontario Canada
Posts: 138


If you test and find 12v at the motor gently and I do mean gently tap the housing of the motor sometimes a brush can get stuck.
__________________
LIFE'S A JOURNEY PACK WELL



CF33LF PROVINCIAL EDITION
SWAILES is offline   Reply With Quote
Old 08-06-2010, 09:50 AM   #4
New Camper
 
Join Date: May 2009
Location: Calgary, AB
Posts: 4
Thanks for the suggestions. We located a broken connection and the sideout now works! We are off tomorrow (Sat. Aug. 7th) on a 2 week trip to Great Falls, MT (2 days),Yellowstone area (5 days),Heyburn State Park on the south end of Lake Coeur D'Alene(5 days) and finishing up at Riverside State Park outside of Spokane, WA (2 days). If you happen to see a Cruiser 30SK being pulled bya 2008 grey Silverado Z71 Duramax with Alberta plates - waveor stop and say high.



Cheers!



KJPCalgary1
KJPCalgary1 is offline   Reply With Quote
Old 08-06-2010, 03:14 PM   #5
Family Vacation Member
 
SWAILES's Avatar
 
Join Date: Jul 2010
Location: Ontario Canada
Posts: 138
Safe travels
__________________
LIFE'S A JOURNEY PACK WELL



CF33LF PROVINCIAL EDITION
SWAILES is offline   Reply With Quote
Old 08-06-2010, 03:44 PM   #6
Full Time Camper
 
Stan's Avatar
 
Join Date: Apr 2006
Location: Oak Harbor, WA
Posts: 1,994
Where was the broken connection? I have the same floorplan and am curious.

__________________
Stan and Terri
Oak Harbor, WA
2008 Chevy 2500HD D/A
2007 Cruiser CF30SK
Glide Ride Pin Box
Reese 16K Slider
Stan is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 04:28 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×