Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-31-2019, 07:17 PM   #1
Weekend Camper
 
Join Date: Jun 2018
Location: Texas
Posts: 10
Tank monitor dead, no water heater, no power zone 1 and 3

I have a Sunset Trail 336BH. For a while, the water heater only worked on electric. I bought a new circuit board, installed it, and neither gas or electric worked. Put the old one back in, electric worked. The next time I used the trailer, I got no hot water on electric. Fuse was blown on the board. Replace with a 5amp bc the parts house didn’t have a 2amp, electric water heater worked. This weekend, no hot water again. Tried using the new one I bought, fuse blew. Put the old one back in, and all of the sudden no lights when the switch for electric or gas was flipped. Also, the lights for the tank monitor didn’t light up.

I checked breakers, and fuses. I even pulled fuses to check them, but I noticed on zone 1 and zone 3 fuses, once pulled there wasn’t a red light that came one that would indicated a broken circuit (from no fuse or blown fuse). The water pump switch still lights up on the panel, and all the lights work, slides, awning, etc on the panel. The AC works, as well as the furnace. The furnace has been acting strange lately though, but I don’t know if it’s related. I was having an issue occasionally that the furnace would kick on when activated, run a couple cycles and never come back on unless I turned the climate control to off, waited to hear a click, then turn the heater back on. Again, it would cycle 2 or 3 times and never come back on. I did the mysterious breaker trick on the actual furnace, and it worked fine again for weeks.

What am I not getting here? Possible loose ground somewhere??
__________________
2018 Sunset Trail 336BH
RV Whisperer is offline   Reply With Quote
Old 04-01-2019, 06:47 AM   #2
Weekend Camper
 
Join Date: Aug 2018
Location: TN
Posts: 27
1) All these are 12vdc CONTROL; have you checked your battery charge status? i.e voltage? Checked battery water level? Re: circuit board, 5a probably blew the board vs blowing fuse, whatever the problem is (maybe damaged wire?) NEVER good idea to oversize a fuse.
TerryH is offline   Reply With Quote
Old 04-01-2019, 07:41 AM   #3
Weekend Camper
 
Join Date: Jun 2018
Location: Texas
Posts: 10
Battery status indicator doesn’t work either. Battery is fine. I agree about the fuse, and at the time I didn’t have a choice.
__________________
2018 Sunset Trail 336BH
RV Whisperer is offline   Reply With Quote
Old 04-01-2019, 12:52 PM   #4
Site Team
 
mark5w's Avatar
 
Join Date: Sep 2012
Location: PA
Posts: 4,754
Check the wires at the back of the water heater where the heating element is. One of mine loosened up and gave a similar problem to yours. Make sure all power off.
__________________
Mark & Susan
Lehighton, Pennsylvania

'13 Cruiser Patriot 335SS - '13 Ford F150 SCREW - PullRite Superslide - Roadmaster Active Suspension
Member - "Northeast Adventures RV Rally Group" & "Mason-Dixon Bunch"
mark5w is offline   Reply With Quote
Old 04-07-2019, 02:11 PM   #5
Weekend Camper
 
Join Date: Mar 2018
Location: Illinois
Posts: 55
I am now on my third 4th circuit board. I had all the same issues as you. I am glad they have all been replaced under warranty.
smoke33 is offline   Reply With Quote
Old 04-12-2019, 06:30 PM   #6
Seasonal Camper
 
mapachoo's Avatar
 
Join Date: Jan 2009
Location: Arvada,Colorado
Posts: 259
We lost the fridge and one slide on the Cruiser, turned out it was the wire going to the breaker coming off the battery they are crimp fittings and can vibrate loose. Check those connections in the battery compartment
__________________
1997 ford f-250 ps

2019 Volante 240RL
mapachoo is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 04:21 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×