Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-12-2017, 11:47 AM   #1
Seasonal Camper
 
Join Date: Mar 2016
Location: NH
Posts: 285
Water heater keeps coming on

Have a 10 gallon DSI water heater. Turn it on gas with inside switch. Fires up, runs 15-20 minutes, water is hot. Then about every 5-10 minutes after that with no use, it fires up again and runs 30 seconds to a minute or so. Haven't timed it.

Was thinking it could just be that it's cold out, around 40-50 degrees F so maybe it is cooling off, but seems kind of fast to cool off enough to relight. Any thoughts?
__________________
2016 Cruiser 315RL
She's a beauty!
Now I just need a truck.

SeanRN is offline   Reply With Quote
Old 05-12-2017, 12:35 PM   #2
Full Time Camper
 
MartyinSC's Avatar
 
Join Date: Feb 2015
Location: SC
Posts: 590
Sounds like a bad thermostat on the unit itself. There should be a few degrees separation between "kick on" and "kick off" to prevent such rapid cycling. Short of replacing this major component (integral with gas valve), I don't know if there is any adjustment. My manual is of no help. Anybody else know?
__________________
Marty and Martha
2015 Z-1 211RD
2012 Nissan Titan
Dalzell SC
2015 - 9 Trips, 41 Nights, 6555 miles!
2016 - 10 Trips, 44 Nights, 3135 miles!
MartyinSC is offline   Reply With Quote
Old 05-12-2017, 12:42 PM   #3
Seasonal Camper
 
Join Date: Mar 2016
Location: NH
Posts: 285
Quote:
Originally Posted by MartyinSC View Post
Sounds like a bad thermostat on the unit itself. Short of replacing this major component (integral with gas valve), I don't know if there is any adjustment.
I was afraid it might be something like this. We usually turn it on, use it and turn it off. I noticed the cycling last Sunday. I stayed at camp last night, was 45 overnight. I woke up at 5am, flipped the switch and hopped back into bed. I heard it run and stop, then the cycling started. Ugh.
__________________
2016 Cruiser 315RL
She's a beauty!
Now I just need a truck.

SeanRN is offline   Reply With Quote
Old 05-12-2017, 04:57 PM   #4
Seasonal Camper
 
Join Date: Mar 2016
Location: NH
Posts: 285
The hot water heater is cycling, on for about 20 seconds about every 3 1/2 minutes.
__________________
2016 Cruiser 315RL
She's a beauty!
Now I just need a truck.

SeanRN is offline   Reply With Quote
Old 05-18-2017, 06:22 PM   #5
Seasonal Camper
 
Join Date: Mar 2016
Location: NH
Posts: 285
Fixed

That was an easy fix. $11 parts pack on Amazon and 10 minutes.
Attached Images
File Type: jpg WH Tstat.jpg (244.1 KB, 4 views)
__________________
2016 Cruiser 315RL
She's a beauty!
Now I just need a truck.

SeanRN is offline   Reply With Quote
Reply

Tags
water heater

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 07:29 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.