Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-12-2014, 12:12 PM   #1
Weekend Camper
 
Join Date: Sep 2014
Location: GA
Posts: 16
Question Water Heater Will Not 'Start'

So here we go again........just got the unit back from 2 weeks in service and now the hot water heater will not turn on. Completely dead.

It is an Atwood MPD 93755 6 Gal Electronic Ignition unit installed in a brand new 2014 Crossroads Z-1 25 BHS. It will not work on Electric or Gas.

Gas in the unit works as the Furnace will ignite & produce heat and the Stove top works. Same with electrical devices. Everything else works.

The switches that control operation in the cabin (the gas and electric) light and stay lit, but that appears normal from what I am reading. The switch/controls are on the top right of the photo below - just above the stereo. One is the water pump (left switch) middle switch is the gas hot water heater operation and the right switch is the electric hot water heater operation switch.

I also tried with and without city water hooked up.

Anyone else have the same issue and know the solution? Thanks!

RVBoater is offline   Reply With Quote
Old 10-12-2014, 12:16 PM   #2
Full Time Camper
 
Stan's Avatar
 
Join Date: Apr 2006
Location: Oak Harbor, WA
Posts: 1,980
Was the service work completed that you mentioned on the water heater?? Could they have pulled fuses and flipped breakers?
__________________
Stan and Terri
Oak Harbor, WA
2008 Chevy 2500HD D/A
2007 Cruiser CF30SK
Glide Ride Pin Box
Reese 16K Slider
Stan is offline   Reply With Quote
Old 10-12-2014, 12:21 PM   #3
Weekend Camper
 
Join Date: Sep 2014
Location: GA
Posts: 16
No sir. The service work was on the awning, some bad wallpaper seams (which they didn't fix) and a bad door latch. I checked the 2A fuse inside the rear access panel on the circuit board - its fine.

The only other 'fuse' is the circuit breaker itself which is not tripped.

I let the electric run for 30+ minutes and the water was no warmer. I also plugged into a generator to see if a load was put on when I flipped the electric WH switch and nothing. No change - so there is no doubt its not heating on electric either. I know for sure its not heating on gas because it simply won't fire.
RVBoater is offline   Reply With Quote
Old 10-12-2014, 01:05 PM   #4
Full Time Camper
 
Stan's Avatar
 
Join Date: Apr 2006
Location: Oak Harbor, WA
Posts: 1,980
Believe there is also a 12v fuse in the CB panel panel. Forget what it is labeled but it's not Water Heater. This supplies power to the relays.
__________________
Stan and Terri
Oak Harbor, WA
2008 Chevy 2500HD D/A
2007 Cruiser CF30SK
Glide Ride Pin Box
Reese 16K Slider
Stan is offline   Reply With Quote
Old 10-12-2014, 01:40 PM   #5
Site Team
 
DavisK's Avatar
 
Join Date: Jan 2014
Location: VA
Posts: 1,197
Is the bypass valve closed and the inlet valve open to the water heater?
__________________

2013 Silverado 2500HD LTZ CC 6.6L Duramax Diesel
2014 Sunset Trail SF270BH
Holly & Buster, mini Dachshunds
2016: 1 trip, 3 nights in 1 state, 316 miles
2015: 5 trips, 18 nights in 3 states, 2707 miles
2014: 5 trips, 14 nights in 3 states, 2426 miles
DavisK is offline   Reply With Quote
Old 10-12-2014, 01:48 PM   #6
Weekend Camper
 
Join Date: Sep 2014
Location: GA
Posts: 16
Yes sir. Water is flowing correctly at the unit. The instructions leave alot to be desired but I assume the way you regulate temperature is by mixing cold water with the hot water return. Otherwise no thermostat.

No fuses either. Checked every one.

I'm at a total loss outside of an incorrectly wired unit. Or defective unit. Not really logical as it's all brand new.
RVBoater is offline   Reply With Quote
Old 10-12-2014, 01:53 PM   #7
Full Time Camper
 
harley's Avatar
 
Join Date: Aug 2012
Location: Belle River , Ontario
Posts: 1,616
close the bypass all the way . regulate hot water at the taps...
__________________


It was a rainy few days at Algonquin Prov park...tarps kept us dry.
Wayne --Belle River (Windsor), Ontario
2013 Sunset Trail Reserve 25RB..
2015 White Chev Silverado 2500HD 4x4 (6.0 l gasser)
2003 Mountain Star 890SBRX Truck Camper
harley is offline   Reply With Quote
Old 10-12-2014, 02:14 PM   #8
Weekend Camper
 
Join Date: Sep 2014
Location: GA
Posts: 16
Tried
Nothing. I hoped it would be that simple.
RVBoater is offline   Reply With Quote
Old 10-12-2014, 04:45 PM   #9
Weekend Camper
 
Join Date: Sep 2014
Location: GA
Posts: 16
By the way - my RV is so new that I messed up the model in the original post. Its a 2014 Z-1 252BH (NOT at 25BHS as originally posted).
RVBoater is offline   Reply With Quote
Old 10-12-2014, 05:21 PM   #10
Full Time Camper
 
anaro's Avatar
 
Join Date: Jan 2011
Location: Mebane, NC
Posts: 2,394
When you check the water heater overflow do you get water out? This really sounds like a bypassed water heater.
__________________

2014 Chevy Silverado 3500 SRW Duramax
2011 Zinger ZT26BL-sold
2014 Sabre 34REQS

***Member of the Mason-Dixon Group***
anaro is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 09:49 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.