Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-25-2013, 01:42 AM   #1
Weekend Camper
 
Glenn996's Avatar
 
Join Date: May 2013
Location: Halifax, NS
Posts: 32
I have a 2014 Sunset Trail 29SS. We love it and have camped 30 nights this summer so far. On 2 trips where we were dry camping, I noticed the water pressure is incredibly lousy. When hooked up to city water it's fine everywhere in the trailer. When on pump it sucks everywhere. I'm guessing there's a kink somewhere, but thought I'd ask before I start tracing water lines from the pump. Any ideas?
__________________
2014 Sunset Trail 29SS
2006 Jetta TDI
1978 Porsche 911 Modified
2004 Grizzly 660
2005 C4S (sold)
Glenn996 is offline   Reply With Quote
Old 07-25-2013, 01:47 AM   #2
Seasonal Camper
 
Beamer5's Avatar
 
Join Date: Feb 2013
Location: United States
Posts: 285
Sounds pretty typical to me. If you had a kink it would be lousy all the time even with city water.
__________________
2015 GMC Sierra 1500 Crew Cab Z71 4X4 3.42
2013 CrossRoads Sunset Trail Super Lite 250RB
Beamer5 is offline   Reply With Quote
Old 07-25-2013, 01:49 AM   #3
Full Time Camper
 
Stan's Avatar
 
Join Date: Apr 2006
Location: Oak Harbor, WA
Posts: 1,980
Just thinking out loud here but it sounds like an issue near the pump, water tank and city hookup. I assume these are in the same vicinity within your rig. Try placing a bucket of clean water at the pump and sucking it up with the winterizing hose. If your pressure/volume returns that might indicate that the problem is in the fresh water line going to the pump from the water tank. It may be kinked.
__________________
Stan and Terri
Oak Harbor, WA
2008 Chevy 2500HD D/A
2007 Cruiser CF30SK
Glide Ride Pin Box
Reese 16K Slider
Stan is offline   Reply With Quote
Old 07-25-2013, 01:55 AM   #4
Full Time Camper
 
Hunter11's Avatar
 
Join Date: Oct 2004
Location: Central Texas
Posts: 2,510
This post might be of some help.



http://forums.crossroadsrv.com/forum...-factory#59806
__________________
17 Chevy 3500 DRW 4X4
16 Mobile Suites 36RSSB4
2 Mini Dachshunds
Hunter11 is offline   Reply With Quote
Old 07-25-2013, 07:11 AM   #5
Site Team
 
Join Date: Dec 2007
Location: WI.
Posts: 7,605
If you don't find a kinked line to be the problem here's another thought. The pump on our rig has a filter, occasionally I've had to take it off and clean the screen. It seems to suck up debris from the tank and it will plug the screen.

__________________
2008 Cruiser CF26RK
2013 Ford Eco-Boost
Heavy duty payload - Max tow
Lloyd is offline   Reply With Quote
Old 07-25-2013, 12:39 PM   #6
Seasonal Camper
 
Join Date: Mar 2007
Location: Ohio
Posts: 388
You might check the valve that switches the water intake from the tank to the rv antifreeze hose. I had a similar issue 1 time. I had apparently bumped the valve while moving things around in the storage near the pump and it was partly open which caused it to draw a little bit of air instead of just water. The pressure was weak but suprisingly it didn't sputter at the faucet. My guess is that the intake hose is kinked like everyone says but you might want to check.
Lonnie
__________________
07 Cruiser 29BT

04 2500 Hemi Ram Quad Cab
Chuck N. Wined is offline   Reply With Quote
Old 07-25-2013, 01:00 PM   #7
Weekend Camper
 
Join Date: Aug 2009
Location: NE Kanas
Posts: 30
Might be overly simple but I had the same problem and finally checked all the restrictors and screens on the faucets an found the fouled with hard water deposits. Cleaned them all, bathroom and kitchen and the problem was solved.



Good luck!
Kevin from K is offline   Reply With Quote
Old 07-26-2013, 09:01 AM   #8
Weekend Camper
 
Glenn996's Avatar
 
Join Date: May 2013
Location: Halifax, NS
Posts: 32
Thanks for the input. I'm taking it out next week so will spend some time trying to track it down. Thanks again.
__________________
2014 Sunset Trail 29SS
2006 Jetta TDI
1978 Porsche 911 Modified
2004 Grizzly 660
2005 C4S (sold)
Glenn996 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 11:41 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.