Reply
 
Thread Tools Search this Thread Display Modes
 
Old 04-21-2015, 08:17 PM   #1
Weekend Camper
 
Join Date: Nov 2014
Location: WA
Posts: 79
BR Slide Works Sometimes, Sometimes Not

Have new 2015 Rushmore Springfield. Haven't had it on the road yet, but have needed to operate slides when getting the inside setup. The kitchen/living room slides work fine. On Saturday, had to push the "out" side of the bedroom rocker switch 6 or 7 times before the slide would operate. A few hours later, had to do the same to get it "in". On Sunday, same story when getting it "out", but no problem getting it in. On Monday, no problem at all.

Anyone seem this kind of slide behavior?
gepaine is offline   Reply With Quote
Old 04-21-2015, 09:02 PM   #2
Site Team
 
mark5w's Avatar
 
Join Date: Sep 2012
Location: PA
Posts: 4,716
Check connections to switch. You'll have to unscrew panel. Same thing for me, loose wire connection.
__________________
Mark & Susan
Lehighton, Pennsylvania

'13 Cruiser Patriot 335SS - '13 Ford F150 SCREW - PullRite Superslide - Roadmaster Active Suspension
Member - "Northeast Adventures RV Rally Group" & "Mason-Dixon Bunch"
mark5w is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 12:33 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.