Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-05-2013, 11:59 AM   #1
Weekend Camper
 
Jamestn's Avatar
 
Join Date: Jun 2013
Location: Tennessee
Posts: 68
Picked up my new Rushmore Lincoln today. Walk thru went great and everything worked. Got home and plug unit up to 50 amp and hardly anything works. No slide outs, no leveler, no frig, no air. Microwave does work. There is a green light blinking in fuse box. I do not here a convertor. Any ideas.

__________________
James & Jennie Hawes
2014 Rushmore Lincoln
2004 Dodge Ram 3500 dually 4X4 http://i1302.photobucket.com/albums/...psa982e7be.jpg[/URL]
Jamestn is offline   Reply With Quote
Old 07-05-2013, 12:23 PM   #2
Full Time Camper
 
Tim D's Avatar
 
Join Date: May 2013
Location: So IL
Posts: 1,811
Is the service newly installed? Has it been verified that it works correctly?
__________________

Tim
13 ST25RB
08 F-250 SC 6.8L XLT 4x4
Tim D is offline   Reply With Quote
Old 07-05-2013, 12:25 PM   #3
Full Time Camper
 
Stan's Avatar
 
Join Date: Apr 2006
Location: Oak Harbor, WA
Posts: 1,980
Since everything worked during the PDI, I would suspect your home power. If your comfortable with electricity, check your 50A service and see if your really do have two 120v lines and then check your rig to see if two 120v power lines are getting to the converter/power panel. I would think one of your main lines is not working (breaker tripped? or bad???).
__________________
Stan and Terri
Oak Harbor, WA
2008 Chevy 2500HD D/A
2007 Cruiser CF30SK
Glide Ride Pin Box
Reese 16K Slider
Stan is offline   Reply With Quote
Old 07-05-2013, 02:01 PM   #4
Weekend Camper
 
Jamestn's Avatar
 
Join Date: Jun 2013
Location: Tennessee
Posts: 68
update. Found that the four 25amp fuses for reverse battery was blown. Replace fuses and everything worked except 3 more blown 15amp fuses. Replaced the3 fuses and now 1 of the 3 blows everytime I put new fuse in. The fuse that blows is the aux fuse. I am 99 percent sure this goes to radio outside. The radio doesn't work ( no fuse in aux) and it smells hot.
__________________
James & Jennie Hawes
2014 Rushmore Lincoln
2004 Dodge Ram 3500 dually 4X4 http://i1302.photobucket.com/albums/...psa982e7be.jpg[/URL]
Jamestn is offline   Reply With Quote
Old 07-05-2013, 02:16 PM   #5
Weekend Camper
 
Jamestn's Avatar
 
Join Date: Jun 2013
Location: Tennessee
Posts: 68
Just thinking. The only thing I have found that don't work while being plugged up is the stereo outside. It keeps blowing fuses. Wonder if that is because it is a car radio and there may be an issue convertor to 12 volts. Only one fan (top one) in the electric box works (convertor?)
__________________
James & Jennie Hawes
2014 Rushmore Lincoln
2004 Dodge Ram 3500 dually 4X4 http://i1302.photobucket.com/albums/...psa982e7be.jpg[/URL]
Jamestn is offline   Reply With Quote
Old 07-05-2013, 03:48 PM   #6
Weekend Camper
 
Jamestn's Avatar
 
Join Date: Jun 2013
Location: Tennessee
Posts: 68
2nd update. Blew more reverse battery fuses and more light and refrig fuse when I turned battery switch on. Went to battery and found white on pos and black on neg. Researched on internet shows that white should be neg and black pos. I switched cables and and replaced fuses. Again, everything works except aux. It blew a fuse again. I think damaged has been done to convertor. Salesman told me that technician was suppose to put new battery in unit. I think he hooked it up wrong and it was not turned on until I got it home. During walk-thru they used shore line.

__________________
James & Jennie Hawes
2014 Rushmore Lincoln
2004 Dodge Ram 3500 dually 4X4 http://i1302.photobucket.com/albums/...psa982e7be.jpg[/URL]
Jamestn is offline   Reply With Quote
Old 07-06-2013, 03:42 AM   #7
Weekend Camper
 
Jamestn's Avatar
 
Join Date: Jun 2013
Location: Tennessee
Posts: 68
Well, took the unit to another rv center just 25 minutes away The outside radio still blows fuses. Technician says there is a short in the wiring somewhere. Everything else is working now. Wwwhheewww. Plan on leaving for Myrtle beach tomorrow morning. I will take unit back for warranty on the radio when I get back from the beach. I also found a 2 small cracks on the bathroom door that needs to be addressed. The rv center I went to today would not recognize crossroad warranty (They sell mainly cedar creeks and a few other brands) because the technician said that they can't get crossroads to pay for previous warranty problems. She said that crossroads owes them money from last year. I guess I will make sure that I have a good list of everything needed when I go back to my dealership for service since they are over 2 hrs away.
__________________
James & Jennie Hawes
2014 Rushmore Lincoln
2004 Dodge Ram 3500 dually 4X4 http://i1302.photobucket.com/albums/...psa982e7be.jpg[/URL]
Jamestn is offline   Reply With Quote
Old 07-06-2013, 07:55 AM   #8
Full Time Camper
 
mike06081969's Avatar
 
Join Date: Feb 2013
Location: Tennessee
Posts: 581
Good luck on your trip, James. I hate to hear that you are having problems so soon.
__________________
Mike in Tennessee
2007 Cruiser 30QB
2008 Ford F250 Lariat 4x4 6.4 Powerstroke
Valley 16K slider
Ride-Rite air bags
mike06081969 is offline   Reply With Quote
Old 07-09-2013, 02:31 PM   #9
Family Vacation Member
 
Rushmore2011's Avatar
 
Join Date: May 2013
Location: Lafayette LA
Posts: 140
Wow!Hope get resolved soon
Good Luck
__________________
Rushmore 38CK , f350 Dually
Rushmore2011 is offline   Reply With Quote
Old 07-09-2013, 11:22 PM   #10
Weekend Camper
 
Join Date: Apr 2013
Location: New Richmond,Oh
Posts: 46


I hope your trip goes better, we just bought a 2014 Lincoln Rushmore also, let me know how the height is on your front jacks while towing, Iam installing a hitch this week on a F-350 and had seen another comment on this. Thanks
RICK7458 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Crossroads Registry

Z-1

kvmllr

StormPOD

ZT211RD
Add your Crossroads RV
» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 11:30 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.