Reply
 
Thread Tools Search this Thread Display Modes
 
Old 04-22-2013, 11:28 PM   #1
Weekend Camper
 
Join Date: Apr 2013
Location: New Richmond,Oh
Posts: 46


I am about a 2 week owner of a 2014 Lincoln Rushmore, and have read several problems with water following the lower rail of the slide, has anyone contacted Crossroads about this, it seems that they would want to have a fix instead of having a bad reputation.
RICK7458 is offline   Reply With Quote
Old 04-23-2013, 12:10 AM   #2
Full Time Camper
 
Hunter11's Avatar
 
Join Date: Oct 2004
Location: Central Texas
Posts: 2,510
"it seems that they would want to have a fix instead of having a bad reputation."



You would certainly think so.......
__________________
17 Chevy 3500 DRW 4X4
16 Mobile Suites 36RSSB4
2 Mini Dachshunds
Hunter11 is offline   Reply With Quote
Old 04-23-2013, 12:39 AM   #3
Full Time Camper
 
Join Date: Nov 2006
Location: Bradley, Il
Posts: 1,018


It has been a known problem with the Schwintek slide for quite awhile. Do a search on the forum for what others have done.
__________________
Dale & Carol
Bradley, Il
2007 F-250
2010 CF30SK Patriot
2007 CF30SK
dalemac377 is offline   Reply With Quote
Old 04-23-2013, 11:43 PM   #4
Weekend Camper
 
Join Date: Apr 2013
Location: New Richmond,Oh
Posts: 46

Thanks, Dale
RICK7458 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 09:22 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.