Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-07-2016, 08:46 AM   #1
Weekend Camper
 
Join Date: Nov 2014
Location: ny
Posts: 18
Generator not charging batteries?

Does anyone else have this issue in their Elevation?
markovwgti is offline   Reply With Quote
Old 01-27-2016, 12:38 PM   #2
Weekend Camper
 
Join Date: Aug 2015
Location: NC
Posts: 17
I had a similar problem with my Talladega. It didn't seem like my generator was charging the battery properly. I decided to take the battery out and have it tested. Turns out the battery had a bad cell in it. I've only had the trailer for 6 months and it was brand new when I bought it. Took the battery back to the dealer and they gave me a brand new one. Everything seems to be great now. Hope this helps,

Bill
__________________

Bill and Kim Wandrack
Wake Forest NC
2015 Crossroads Elevation Talladega
2012 Ram 3500 Laramie Longhorn DRW
6.7L High Output Diesel
AISIN 6 spd auto 4:10
bwandrack is offline   Reply With Quote
Old 01-27-2016, 07:51 PM   #3
Full Time Camper
 
Join Date: Oct 2011
Location: Mn
Posts: 545
Thanks for the tip on check the battery cells.
__________________
Lee & Jane and Black Lab Zoey
2008 Ford F250 CC Lariat 6.8L
2011 Crossroads Cruiser 31RK
Faribault MN
LeBo is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 02:25 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.