Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-21-2015, 06:43 AM   #1
New Camper
 
Join Date: Nov 2015
Location: Michigan
Posts: 7
Slide out problem & dealer issue

National RV in Bellville Mi has had my 14 Elevation more than I have for the last year and a half. The living room slide has had multiple repairs and they don't seem to have the ability to repair appropriately. The Lippert thru frame slide has broken gears twice (the second time because NATLRV installed the wrong one) I called Lippert to get the right tooth ratio needed and then shared with NATLRV. Now they say the whole Lippert unit is screwed up and I have waited months for supposed parts. Does anyone know of someone who specializes in installation and setup of the Lippert unit. Lippert does not and can't recommend anyone. Luckily I bought a 7 year warranty package and they have been covering all cost. I just want to get this slide repaired once and for all........Thanks
Campy is offline   Reply With Quote
Old 11-21-2015, 06:45 AM   #2
Site Team
 
Join Date: Dec 2007
Location: WI.
Posts: 7,570
Have you contacted the factory/Cross Roads?
__________________
2008 Cruiser CF26RK
2013 Ford Eco-Boost
Heavy duty payload - Max tow
Lloyd is offline   Reply With Quote
Old 11-21-2015, 10:53 AM   #3
Site Team
 
mark5w's Avatar
 
Join Date: Sep 2012
Location: PA
Posts: 4,688
Here is a Lippert service center in Mi, not sure how far away it is from you. Innovative Design Solutions (IDS) 6801 15 Mile Rd. Sterling Heights, MI 48312 248-583-1010 248-583-0527
__________________
Mark & Susan
Lehighton, Pennsylvania

'13 Cruiser Patriot 335SS - '13 Ford F150 SCREW - PullRite Superslide - Roadmaster Active Suspension
Member - "Northeast Crossroad Rally" & "Mason-Dixon Bunch"
mark5w is offline   Reply With Quote
Old 11-21-2015, 12:57 PM   #4
New Camper
 
Join Date: Nov 2015
Location: Michigan
Posts: 7
Lippert service

Thanks for the info I will call them !!!,
Campy is offline   Reply With Quote
Old 11-25-2015, 03:33 AM   #5
Weekend Camper
 
Join Date: May 2013
Location: Missouri
Posts: 77
Hey Campy,
I took mine right to the Lippert Service center in Indiana. They found my slide was a 1/2" out of square. Replaced and shimmed the track system. Spent nearly $900 but at least its fixed and working. Camper has 30k plus on it, so its definitely been used. Very satisfied with the service facility, at least you get some body with knowledge and experienced with the system.
HCFR34 is offline   Reply With Quote
Old 11-25-2015, 03:35 AM   #6
New Camper
 
Join Date: Nov 2015
Location: Michigan
Posts: 7
Thumbs up Thanks

I did in fact just found them and have been in contact with The Goshen IN service center.......Thanks for the response.
Campy is offline   Reply With Quote
Old 11-25-2015, 03:40 AM   #7
Weekend Camper
 
Join Date: May 2013
Location: Missouri
Posts: 77
They are a little backed up but at least know what their doing. We just incorporated it into our travels. Been there 3 times, 2 were under warranty and this time I was direct pay. oh well, just wanted it fixed.
HCFR34 is offline   Reply With Quote
Old 11-25-2015, 04:16 AM   #8
New Camper
 
Join Date: Nov 2015
Location: Michigan
Posts: 7
That's good to know. I have an appointment via phone to make arrangements today. I only live 40 miles from them but wasn't aware they had a service center. I had called earlier and was told they only manufacture.
Campy is offline   Reply With Quote
Old 11-25-2015, 04:35 AM   #9
Weekend Camper
 
Join Date: May 2013
Location: Missouri
Posts: 77
I don't have my original info with me, I was there in October, found this on the internet. Service Center on 1701 Century Dr, Goshen In. Number listed was 866-524-7821
I talked to a Collete, not sure on the spelling. Let me know if that works.
HCFR34 is offline   Reply With Quote
Old 11-25-2015, 04:51 AM   #10
New Camper
 
Join Date: Nov 2015
Location: Michigan
Posts: 7
Yes Collete is the person I spoke with yesterday. And will be speaking with today. They were very helpful. Hope this is on track for resolve as I would really like final fix. I believe the issues were from the initial install not from my dealer. Thanks again.
Campy is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 11:09 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.