Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-26-2013, 02:18 AM   #1
Family Vacation Member
 
hippy45's Avatar
 
Join Date: Sep 2012
Location: Ontario Canada
Posts: 199
Hi all, got a new Z1 last fall and had brake surge and pull from the start. Had the wheels off to paint rims and balance, and all the drums seemed to drag the same. Changed controllers, still the same.
Went camping this weekend with my laser thermometer to check temps. After an hour of driving, i did a couple of stops then pulled over.
Truck front 68c, rear 45c. Trailer all at 20c, except l.f. was 40c. I thought mayb it was the problem, then discovered that it was running about right temp, and othet three are low. (20c is about ambient).
The brakes all click when i jump the 7 pin, and all wiring looks ok.
Is it possible that three are that far out of adjustment?
Any suggestions would b appreciated.
Peter



__________________
2012 Z1 271BH
2009 F150,4.6 3V. 3.73LS,9.75"
hippy45 is offline   Reply With Quote
Old 05-26-2013, 03:38 AM   #2
Full Time Camper
 
fhenn's Avatar
 
Join Date: Jul 2006
Location: Ms
Posts: 2,707
Possible grease in all the drums. I would pull one and check it if there is grease on it clean it and do the rest



__________________
Frank and Janet Henn
2017 380MBH pushing a 2007 Dodge
CDT with a six speed Automatic
Traveling with Hoover and Rainbow the wonder dogs and now with Sunshine the rescue Schnauzer.
fhenn is offline   Reply With Quote
Old 05-26-2013, 09:08 AM   #3
Family Vacation Member
 
hippy45's Avatar
 
Join Date: Sep 2012
Location: Ontario Canada
Posts: 199
Thanks, I will check that tomorrow. I have never greased them yet.
__________________
2012 Z1 271BH
2009 F150,4.6 3V. 3.73LS,9.75"
hippy45 is offline   Reply With Quote
Old 05-27-2013, 07:43 AM   #4
Family Vacation Member
 
hippy45's Avatar
 
Join Date: Sep 2012
Location: Ontario Canada
Posts: 199
Well pulled the drums today, everything looks good. The drums are stamped made in USA, so thats a bonus!
Is it possible the magnets and shoes take time to seat?
They were all very close in adjustment.
Lots of grease in the bearings too.
__________________
2012 Z1 271BH
2009 F150,4.6 3V. 3.73LS,9.75"
hippy45 is offline   Reply With Quote
Old 05-27-2013, 09:33 AM   #5
Full Time Camper
 
fhenn's Avatar
 
Join Date: Jul 2006
Location: Ms
Posts: 2,707
The only other thing I can think about is play with your power setting on the controller. Do the wheels lock up when you are sitting still while holding the controller they should lock up when you move the truck. Once you have the lock than adjust them a little lighter. Remember the brakes on the trailer you want to start to grab a little bit before the truck brakes do

__________________
Frank and Janet Henn
2017 380MBH pushing a 2007 Dodge
CDT with a six speed Automatic
Traveling with Hoover and Rainbow the wonder dogs and now with Sunshine the rescue Schnauzer.
fhenn is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 05:43 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.