Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-26-2016, 08:22 AM   #1
Jan
Weekend Camper
 
Join Date: Jul 2016
Location: PA
Posts: 12
No hot water...help!

Morning everyone,
We've hooked up to a full hook up site at the beach. Our hot water tank will not fill. Why?
Thanks everyone!
Jan
We have a 2015 Crossroads Z-1. 22.5
Jan is offline   Reply With Quote
Old 08-26-2016, 08:24 AM   #2
Site Team
 
Join Date: Dec 2007
Location: WI.
Posts: 7,427
Do you have all the winterizing valves turn to the correct position?
__________________
2008 Cruiser CF26RK
2013 Ford Eco-Boost
Heavy duty payload - Max tow
Lloyd is online now   Reply With Quote
Old 08-26-2016, 09:16 AM   #3
Jan
Weekend Camper
 
Join Date: Jul 2016
Location: PA
Posts: 12
Quote:
Originally Posted by Lloyd View Post
Do you have all the winterizing valves turn to the correct position?
Not sure. Where is the one for the hot water heater tank? Pete
__________________
2015 Crossroads Z-1. 225
Jan is offline   Reply With Quote
Old 08-26-2016, 10:35 AM   #4
Seasonal Camper
 
Join Date: Aug 2015
Location: Tn
Posts: 384
Can you locate the back of your water heater? Check the blue fill line valve. It should be turned to run in parallel with the water line, not 90 degrees against it.
__________________
Burgy
(Kevin and Lisa)
2008 Nissan Titan
2015 ST270BH
http://burgpath.us/photos/index.php?cat=13
Burgy is offline   Reply With Quote
Old 08-26-2016, 10:45 AM   #5
Site Team
 
Join Date: Dec 2007
Location: WI.
Posts: 7,427
__________________
2008 Cruiser CF26RK
2013 Ford Eco-Boost
Heavy duty payload - Max tow
Lloyd is online now   Reply With Quote
Old 08-26-2016, 01:28 PM   #6
Site Team
 
mark5w's Avatar
 
Join Date: Sep 2012
Location: PA
Posts: 4,614
do not turn the hot water heater until it's full of water
__________________
Mark & Susan
Lehighton, Pennsylvania

'13 Cruiser Patriot 335SS - '13 Ford F150 SCREW - PullRite Superslide - Roadmaster Active Suspension
Member - "Northeast Crossroad Rally" & "Mason-Dixon Bunch"
mark5w is offline   Reply With Quote
Old 08-26-2016, 06:55 PM   #7
Jan
Weekend Camper
 
Join Date: Jul 2016
Location: PA
Posts: 12
Thank you...we did it!

Quote:
Originally Posted by Burgy View Post
Can you locate the back of your water heater? Check the blue fill line valve. It should be turned to run in parallel with the water line, not 90 degrees against it.


Thanks, Burgy! Found it. We had to lift the bed to get to the back of the water heater, but it works now! Thanks, again!
__________________
2015 Crossroads Z-1. 225
Jan is offline   Reply With Quote
Old 08-26-2016, 06:57 PM   #8
Jan
Weekend Camper
 
Join Date: Jul 2016
Location: PA
Posts: 12
Thank you, Lloyd! Found it!

Quote:
Originally Posted by Lloyd View Post
We now have hot water, and thanks for all of your help! Pictures are great!
__________________
2015 Crossroads Z-1. 225
Jan is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 06:28 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.