Reply
 
Thread Tools Search this Thread Display Modes
 
Old 12-30-2015, 05:33 PM   #1
Weekend Camper
 
Join Date: Feb 2015
Location: Indiana
Posts: 14
Zinger furnace blowing 15 amp fuse

Ok everyone need some help got my zinger 32db in February this year and at the end of the season we camped one last time it was chilly in morning so used furnace one morning, warmed up camper nicely. Then at some point I noticed the front tv entertainment system would not power on and realized I had blown a fuse of which I had no extras and by then didn't need the furnace anymore. Fast forward to now recently started using the camper for my home office since we have six little ones it was a nice quiet place to work and I have everything that I need since I put a 30 amp plug on outside of garage so it's always plugged in, recently however here in Indiana it's quite cold so I normally just use electric heater in there however it is necessary on very cold days to get the initial chill out of the camper to use furnace and then maintain with electric heater.

All that to get to the problem the furnace is blowing fuses, generally when the unit tries to kick on and it doesn't always do it but it is doing it a lot today I replaced the fuse and turned it on only to blow new one right away. I have warranty just hate to pull it clear north to get serviced but may need to, any help is appreciated.

Tia
__________________
Phil & Laurie
2015 Zinger zt32db
2013 GMC Sierra CC 1500 5.3 L 3.42 rearend
4 way Equalizer WDH
Hightech is offline   Reply With Quote
Old 12-30-2015, 08:35 PM   #2
Full Time Camper
 
Stan's Avatar
 
Join Date: Apr 2006
Location: Oak Harbor, WA
Posts: 1,965
Are you absolutely sure the new fuse was the same amperage? No insult intended. If so, it sounds like the furnace is trying to draw too much current. Does the fan come on and basically sound OK? Not sure why it would blow....shouldn't draw too much current other than the fan.
__________________
Stan and Terri
Oak Harbor, WA
2008 Chevy 2500HD D/A
2007 Cruiser CF30SK
Glide Ride Pin Box
Reese 16K Slider
Stan is offline   Reply With Quote
Old 12-31-2015, 05:49 AM   #3
Weekend Camper
 
Join Date: Feb 2015
Location: Indiana
Posts: 14
No insult taken but yes I'm sure they are all 15 amp except one 40 amp one in the unit. No this fuse prevents the fan from coming on.
__________________
Phil & Laurie
2015 Zinger zt32db
2013 GMC Sierra CC 1500 5.3 L 3.42 rearend
4 way Equalizer WDH
Hightech is offline   Reply With Quote
Old 12-31-2015, 08:09 AM   #4
Full Time Camper
 
Russb's Avatar
 
Join Date: Oct 2009
Location: Texas
Posts: 573
Any chance mud daubers have nested preventing the fan from turning which would cause a higher amp draw?
__________________
Russ
Forney,TX
2010 Cruiser CTX CT29RLX
2009 F-150XLT
Russb is online now   Reply With Quote
Old 12-31-2015, 08:15 AM   #5
Site Team
 
Join Date: Dec 2007
Location: WI.
Posts: 7,470
Good thought Russ.
Any kind of a nest (even mouse) that has been started in there, or any rubbing of any kind can cause additional amp draw.
__________________
2008 Cruiser CF26RK
2013 Ford Eco-Boost
Heavy duty payload - Max tow
Lloyd is offline   Reply With Quote
Old 01-23-2016, 06:28 PM   #6
Weekend Camper
 
Join Date: Feb 2015
Location: Indiana
Posts: 14
Update... It turns out the factory had my furnace wired to the entire front bedroom section of the trailer causing overload on that circuit. It is now wired to its own fuse and works like a charm, that's the good news, bad news is I had to pay for repair so I could get fixed local and now I wait and see if check shows up from crossroads.
__________________
Phil & Laurie
2015 Zinger zt32db
2013 GMC Sierra CC 1500 5.3 L 3.42 rearend
4 way Equalizer WDH
Hightech is offline   Reply With Quote
Old 01-23-2016, 06:39 PM   #7
Full Time Camper
 
Stan's Avatar
 
Join Date: Apr 2006
Location: Oak Harbor, WA
Posts: 1,965
Glad you got it fixed. Hopefully you will get a check fast. Odd they wired it up to the front 12v circuit. Someone really screwed up.
__________________
Stan and Terri
Oak Harbor, WA
2008 Chevy 2500HD D/A
2007 Cruiser CF30SK
Glide Ride Pin Box
Reese 16K Slider
Stan is offline   Reply With Quote
Old 01-23-2016, 06:43 PM   #8
Site Team
 
Join Date: Dec 2007
Location: WI.
Posts: 7,470
Nice to have a report coming back on an issue. Thanks.
Glad you got it figured out and fixed.
__________________
2008 Cruiser CF26RK
2013 Ford Eco-Boost
Heavy duty payload - Max tow
Lloyd is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 05:59 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.