CrossRoads RV Family Forum

CrossRoads RV Family Forum (http://www.crossroadsowners.com/forums/)
-   Hampton (http://www.crossroadsowners.com/forums/f19/)
-   -   Furnace not lighting, control panel dead (http://www.crossroadsowners.com/forums/f19/furnace-not-lighting-control-panel-dead-14229.html)

jschief 08-28-2018 12:22 PM

Furnace not lighting, control panel dead
 
Hey all -

I'm new to the forum, so I apologize if I'm doing this wrong. I searched but couldn't find anything quite like what I'm seeing.

Long story short, my wife and I are living full time in a 2018 Hampton we bought a few months ago. We've had a few issues here and there that we've been able to take care of (shoddy factory wiring has caused two issues so far). Overall we've been pretty happy though.

Fast forward to Sunday. We took our propane tanks off and had them refilled. Hooked them back up and the furnace doesn't seem to do anything. We have no hot water, no heat. To make matters worse, the monitor panel is also dead. I can't check the battery\tank levels, and i'm unsure if the DSI light is actually functioning or not. The switches for the electric and gas heater do not illuminate when they are switched on. The water pump switch illuminates fine when it's on though. Lights and slides work without issue.

Things I've checked so far:
I'm getting a good reading off the battery
Stovetop\oven light up just fine
All 12v systems are running fine when unhooked from 50amp
Fuse for the furnace is fine
Resetting the suburban water heater doesn't seem to do anything
I have no visible pilot light
Resetting breakers doesn't seem to do anything

I'm running out of ideas, but I'm also not an expert. I'm really hoping to save the inevitable $250 for the mobile maintenance man to come out here yet again.

Has anyone else experienced this?

Thanks in advance,
John

Lloyd 08-28-2018 12:40 PM

Have you tried lighting the burners on your stove? Sounds like maybe the lines still have air in them. This is a common problem when you run out of LP. As far as the electrical problem showing up at the same time is odd. Have you check the battery/batteries for water or to see if they are charged?
It's also possible the converter died prematurely.
I see your unit is a 2018 so it must still be under warranty.

jschief 08-28-2018 12:54 PM

Thanks for the reply!

The stovetop and oven light up and hold a flame just fine. Cooked dinner on it last night without any issues.

The battery was pulling 12v when I hit it with the multimeter. Seems like it's fine. I haven't pulled it off to check water levels yet - I can try that tonight.

Converter is my worry too. I really hope that's not the case with a 3 months old trailer :mad:

Papa-T 08-28-2018 02:23 PM

Have you checked all the fuses and breakers in the converter box in case they have one labeled wrong? Could also be an inline fuse on the wire near the battery. Or possibly a fuse behind the display panel.

jschief 08-28-2018 02:57 PM

Good call. I only checked the furnace fuse but not the others. I haven't pulled the monitor panel yet - I can do that tonight as well.

dagst1 08-28-2018 03:00 PM

Hello and welcome. I agree with the air in the lines. You say you used the stove so you have gas there. How far away in the water heater from the stove? If its very far there could still be some air. Have you tried to light the water heater and have someone listen outside to see if it makes a "clicking" sound? As for the electrical if it were mine it would go back to the dealer as it is under warranty. Did everything work before you changed bottles? Hard to believe changing the bottles would have any thing to do with the electrical. Two separate systems.

jschief 08-28-2018 03:29 PM

The water heater is closer to the tanks than the stove. (*edit - they are probably ~4ft from each other physically) That said i'm not sure how the lines are configured, so maybe that's wrong.

AFAIK the ignition is automatic in our trailer - we had a furnace problem (which turned out to be a bad relay) when we first got the trailer. After solving that, it fired right up without any issue. But without the monitor panel working I can't tell if there's a DSI fault or not. Even if there was, i'm not sure how I would solve it. Is there a manual way to ignite it? Or bleed the lines?

Everything was fine before the bottles. When I noticed the furnace issue, I went to check the battery level and the monitor panel lit up for a second and then promptly died. This also happened when the relay went bad, so i'm suspicious that there may be a larger failure.

The dealer may be the solution, but we're permanently parked, which means we're reliant on mobile techs. We just found out that the guy we've used before no longer services our area, so this just became even more real. Sigh. :banghead:

jschief 08-28-2018 09:21 PM

Quote:

Originally Posted by Papa-T (Post 134047)
Have you checked all the fuses and breakers in the converter box in case they have one labeled wrong? Could also be an inline fuse on the wire near the battery. Or possibly a fuse behind the display panel.


Alright, you win! I pulled the monitor panel and naturally there was a 5amp inline fuse that was blown behind it. New fuse and everything fired right up.

Sorta boggles my mind that a fuse would be hidden back there, but whatever. Now I know.

Thanks a ton for the help everyone!

dagst1 08-28-2018 09:53 PM

Happy you got it fixed and it was something simple. And Thanks for posting the outcome as some post a problem and then never post what the fix was. Hope you enjoy your new home.


Happy Camping :dance:

Lloyd 08-29-2018 07:24 AM

That's good news, and thanks for letting us know.:thumb:


All times are GMT -6. The time now is 12:59 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.