Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-12-2021, 06:30 AM   #1
Weekend Camper
 
Join Date: Aug 2020
Location: Ji
Posts: 22
Atwood furnace trouble.

Hello everyone.
This weekend I tried to turn on the furnace and it would not light. The blower worked but no igniter sound. I took the furnace out and checked to see if anything was dirty and not making contact but didnít really see any problems. I put it back together and tried it again and still no go. I tapped the top of the furnace and the igniter sound started and the furnace lit.
Has anyone ever had this trouble before. I am thinking itís a sticky sail switch but not 100%.


2016 sunset trail 32Bh
Chris1981 is offline   Reply With Quote
Old 07-12-2021, 07:48 AM   #2
Weekend Camper
 
divey's Avatar
 
Join Date: Apr 2019
Location: Alberta
Posts: 32
My bet is the sail switch. Been there, done that!
__________________
2019 Cruiser Aire 29SI 5th Wheel - Sold
2018 Ram 2500HD, 6.7 L Cummins Turbo Diesel 4X4

"The smallest act of kindness trumps the greatest of intentions"
divey is offline   Reply With Quote
Old 07-15-2021, 06:20 PM   #3
Family Vacation Member
 
Wingerdinger's Avatar
 
Join Date: Jul 2018
Location: Minnesota
Posts: 218
Atwood furnaces will throw a trouble code, displayed on an LED on the control board. Find the manual for troubleshooting, that way you don't have to guess or throw parts at it.
__________________
Doug and Patience and Shelby the mutt
2015 Crossroads Sunset Trail Reserve ST26RB
2013 Ford F-150 3.5 EcoBoost XLT Supercab 4x4
Wingerdinger is offline   Reply With Quote
Old 07-18-2021, 04:34 PM   #4
New Camper
 
Join Date: Nov 2020
Location: OR
Posts: 1
I would bet on the sail switch also. Also if your battery is low, the fan will not spin fast enough to activate the sail switch. If the sail switch is not activated, the igniter will not fire.
Duke4857 is offline   Reply With Quote
Old 07-19-2021, 07:23 AM   #5
Seasonal Camper
 
Join Date: Mar 2014
Location: MA
Posts: 298
There is an air flow switch which always gets fouled up with dust and hair. clean that and I'll bet you'll get it going.
Do you have pets in your unit?
__________________
Retired U.S. Navy Engineer

2020 Ram 2500 Bighorn 6.7 Diesel
2014 Zinger 27RL
markandkim is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 02:03 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
×