Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-16-2009, 09:44 AM   #1
Weekend Camper
 
Join Date: Mar 2006
Location: Kansas
Posts: 33
Hello,

I was unhooking my Zinger and went to use the electric jack to lower the jack stand and there was no power going to it. It wouldn't even make a sound. I then hooked it up to the land power and still nothing. I have power everywhere else and no breakers are blown. What do you think is the problem. It was working fine before this happened.

Thank you,

Joe
__________________
2000 Ford Excursion

2006 Zinger ZT32QB

Traveling with my wife and 4 kids. Blessing upon Blessing.
JoeKan is offline   Reply With Quote
Old 10-16-2009, 10:37 AM   #2
Full Time Camper
 
mwebber78's Avatar
 
Join Date: Jun 2008
Location: Maine
Posts: 1,250
Send a message via Yahoo to mwebber78
You sure there isn't an in-line fuse between the battery and the power jack? Almost all applications I have seen have a small fuse.
__________________
Mike
2013 Jayco Eagle 334RBTS
Crossroads Forum Lurker
mwebber78 is offline   Reply With Quote
Old 10-16-2009, 01:41 PM   #3
Weekend Camper
 
Join Date: Mar 2006
Location: Kansas
Posts: 33
I'll look again in the morning. Thanks.
__________________
2000 Ford Excursion

2006 Zinger ZT32QB

Traveling with my wife and 4 kids. Blessing upon Blessing.
JoeKan is offline   Reply With Quote
Old 10-16-2009, 02:51 PM   #4
Full Time Camper
 
mwebber78's Avatar
 
Join Date: Jun 2008
Location: Maine
Posts: 1,250
Send a message via Yahoo to mwebber78
The in-line fuses have a green or black waterproof inline receptacle with a little cover. They blend and and may be under the edge of the frame or hiding near your battery box.
__________________
Mike
2013 Jayco Eagle 334RBTS
Crossroads Forum Lurker
mwebber78 is offline   Reply With Quote
Old 10-18-2009, 03:44 PM   #5
Weekend Camper
 
Join Date: Mar 2006
Location: Kansas
Posts: 33
Got if fixed. Thanks for the help. I think it must have been a loose wire.
__________________
2000 Ford Excursion

2006 Zinger ZT32QB

Traveling with my wife and 4 kids. Blessing upon Blessing.
JoeKan is offline   Reply With Quote
Old 10-19-2009, 04:18 AM   #6
Weekend Camper
 
usolm1's Avatar
 
Join Date: Mar 2006
Location: Lindenhurst, NY
Posts: 85
I had the same problem with mine, I had to clean the connector that the fuse goes into.

__________________
Lou, Ilene,Brian,Neil and Heidi the hyperactive weiner dog.

2017 Thor Windsport
36' Motorhome
Pulling 2018 Ford Flex
usolm1 is offline   Reply With Quote
Old 10-26-2009, 08:14 AM   #7
Weekend Camper
 
Join Date: Mar 2006
Location: Kansas
Posts: 33
This problem is happening again. I'm not sure what it is. Does any one have the phone # for crossroads?

Thanks,

Joe
__________________
2000 Ford Excursion

2006 Zinger ZT32QB

Traveling with my wife and 4 kids. Blessing upon Blessing.
JoeKan is offline   Reply With Quote
Old 10-26-2009, 10:45 AM   #8
Full Time Camper
 
fhenn's Avatar
 
Join Date: Jul 2006
Location: MS
Posts: 2,746
Check your battery a bad battery can cause all kinds of things

__________________
Frank and Janet Henn
2000 Monoco Lapalma
being pushed by a 2004 Jeep Grand Cherokee
Traveling with Rainbow the wonder dog and now with Sunshine the rescue Schnauzer.
fhenn is offline   Reply With Quote
Old 10-26-2009, 12:31 PM   #9
Weekend Camper
 
Join Date: Mar 2006
Location: Kansas
Posts: 33
Thanks fhenn, that was the problem.
__________________
2000 Ford Excursion

2006 Zinger ZT32QB

Traveling with my wife and 4 kids. Blessing upon Blessing.
JoeKan is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 10:55 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
×