Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-05-2024, 10:11 AM   #1
New Camper
 
Join Date: May 2024
Location: Alberta
Posts: 2
Unhappy Furrion Back Up Pigtail problem

We picked up our new 2024 Sunset Trail a couple days ago.
It has a pigtail on the back to connect a Furrion or Furrion compatible back up camera system.
I am trying to connect a compatible camera and having no joy. After a whole day wasted on trouble shooting, I am beyond frustrated and wondering if anyone has had similar issues and if so, how you fixed it?

This is what I've tried so far:
* Tested the camera off the trailer as recommended and confirmed both camera and monitor work fine
* Installed the camera by connecting to the pigtail and were getting 'no signal' on the monitor
* As recommended, turned on headlights manually and put tow vehicle in reverse - still no signal
* Tested the 7 pin outlet on the truck and it's working fine (13.5v)
* Tested the Furrion pigtail outlet on the back of the trailer with the tow vehicle in reverse and the headlights on (as before) - no voltage coming from it
* Tested the tow vehicle fuses (all trailer related fuses) - all working fine

I am mystified. I looked on the fuse panel in the trailer and there are no fuses labelled for the back up camera. I don't know what else to try or how to determine where the fault lies.

Any help or suggestions welcome!
Chopthebass is offline   Reply With Quote
Old 05-05-2024, 11:59 AM   #2
Site Team
 
Join Date: Dec 2007
Location: WI.
Posts: 9,187
You might find some help on one of these links.


https://www.crossroadsowners.com/for...wer-17022.html
https://www.crossroadsowners.com/for...sue-16526.html
https://www.crossroadsowners.com/for...ion-13165.html
Lloyd is offline   Reply With Quote
Old 05-05-2024, 12:40 PM   #3
New Camper
 
Join Date: May 2024
Location: Alberta
Posts: 2
Thanks. Looks like I’ll have to take it back and get them to hook it up. Sounds like it’s not actually connected to anything.
__________________
2024 Sunset Trail 285CK
Chopthebass is offline   Reply With Quote
Old 05-08-2024, 02:13 PM   #4
Full Time Camper
 
Papa-T's Avatar
 
Join Date: May 2012
Location: N.C. Mountains
Posts: 2,428
Yea it’s new. Take it back.
__________________
*2016 CAF25SE Cruiser Aire 5er. *2020 Chevrolet 2500 HD Custom
*Ted & Tricia (Mimi - Teacup Poodle/ Sailor - Maltipoo)

*I have tried to live my life so that my family would love me and my friends would respect me. The others can do whatever the Hell they please!Ē óJohn Wayne
Papa-T is offline   Reply With Quote
Old 05-09-2024, 03:45 PM   #5
Weekend Camper
 
Join Date: Jan 2024
Location: Me
Posts: 13
Chopthebsss
Iím not much of a techie guy but in my zinger I took off the rear external mounting plate for the camera position and found a connector to hook up to a camera. But I pulled lightly on this connector and it came right out, it was about 6 inches long. My dealer said this connector was just loosely placed there if needed for that camera type. And that I would have to fish down a bit further and find the real wire and pull it up.
That make any sense?

Stan.
Pstan is offline   Reply With Quote
Old 05-09-2024, 05:41 PM   #6
New Camper
 
Join Date: Jun 2023
Location: TX
Posts: 1
Backup Pigtail

I had the same problem with the backup camera wiring. You have to take off the mounting bracket from the trailer, once you remove it, pull the wire out and Iím sure you will notice that the wire inside the trailer has never been cut or connected. Itís fairly simple after you pull the wire out if the trailer. Good luck. Jon
Chief600 is offline   Reply With Quote
Old 05-10-2024, 09:03 AM   #7
New Camper
 
Join Date: Jan 2024
Location: Wa
Posts: 1
Quote:
Originally Posted by Chopthebass View Post
We picked up our new 2024 Sunset Trail a couple days ago.
It has a pigtail on the back to connect a Furrion or Furrion compatible back up camera system.
I am trying to connect a compatible camera and having no joy. After a whole day wasted on trouble shooting, I am beyond frustrated and wondering if anyone has had similar issues and if so, how you fixed it?

This is what I've tried so far:
* Tested the camera off the trailer as recommended and confirmed both camera and monitor work fine
* Installed the camera by connecting to the pigtail and were getting 'no signal' on the monitor
* As recommended, turned on headlights manually and put tow vehicle in reverse - still no signal
* Tested the 7 pin outlet on the truck and it's working fine (13.5v)
* Tested the Furrion pigtail outlet on the back of the trailer with the tow vehicle in reverse and the headlights on (as before) - no voltage coming from it
* Tested the tow vehicle fuses (all trailer related fuses) - all working fine

I am mystified. I looked on the fuse panel in the trailer and there are no fuses labelled for the back up camera. I don't know what else to try or how to determine where the fault lies.

Any help or suggestions welcome!
I had problems with the Furrion back up compatible wiring on my Crossroads Sunset trailer. I just bit the dust and took it to my dealer. When I got it back they told me something was not done right at the factory, but they took care of it for me.



I am thankful to Poulsbo RV for the great service guys in Sumner!
Cmcvay is offline   Reply With Quote
Old 05-12-2024, 03:52 PM   #8
New Camper
 
Join Date: Feb 2024
Location: Ohio
Posts: 9
Yeah, I just went through this myself. The "Camera Prep" is pointless at best and fraudulent at worst.

If you completely remove the Furion camera mount and pull out the power connector, you'll find that the power connector is not wired into the trailer's electric at all. It's zip-tied to the wire between marker lights, but you need to do the actual wiring.

The challenge will be that they coat the screws and all around the bracket with sealant, making it impossible to remove without destroying the screws, and in my case, the bracket broke too.

Also, keep in mind that since it's wired to the marker lights, the camera will only be powered when at least your running lights are on.
__________________
2021 Ford F150 LTE (V8 Gas)
2023 Sunset Trail SS258RD
Bob, Jeri, Nash (Great Dane) & Gibbs (St. Bernard)
BobRed0965 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 05:54 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
×