Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-25-2009, 02:34 AM   #21
Seasonal Camper
 
GeorgeG's Avatar
 
Join Date: Dec 2008
Location: Pittsburgh
Posts: 433
Send a message via Yahoo to GeorgeG
This is what I have found out since last post. I have 2 problems here. First,I'm not getting enough water from the tank to the pump. Water is getting there, but not enough. Still must have a restriction. Second, the pump only pumps for about 5 minutes and then nothing. I connected pump up in a bucket and then turned it on. I had even higher flow than in the trailer for the first 5 minutes. Then it barely puts out a trickle and makes noise. Shut it off for about 5 minutes and try again, it pumps good then down to a trickle.
__________________
George

Nights camped in 2010 = 009
GeorgeG is offline   Reply With Quote
Old 03-25-2009, 03:26 AM   #22
Site Team
 
Join Date: Dec 2007
Location: WI.
Posts: 9,160
George:
Is there a filter on the end of your pump?


Lloyd is offline   Reply With Quote
Old 03-25-2009, 03:32 AM   #23
Seasonal Camper
 
GeorgeG's Avatar
 
Join Date: Dec 2008
Location: Pittsburgh
Posts: 433
Send a message via Yahoo to GeorgeG
Quote:
Originally Posted by Old Farmer
George:
Is there a filter on the end of your pump?


No, bucket test I did above, pump was removed from the trailer.Edited by: GeorgeG
__________________
George

Nights camped in 2010 = 009
GeorgeG is offline   Reply With Quote
Old 03-25-2009, 03:34 AM   #24
Site Team
 
Join Date: Dec 2007
Location: WI.
Posts: 9,160








No[/QUOTE]


That's odd. Most of them have some kinf of filter that screws off.
Edited by: Old Farmer
Lloyd is offline   Reply With Quote
Old 03-25-2009, 03:36 AM   #25
Seasonal Camper
 
GeorgeG's Avatar
 
Join Date: Dec 2008
Location: Pittsburgh
Posts: 433
Send a message via Yahoo to GeorgeG
Shurflo shows them on their web site and installation instructions.
__________________
George

Nights camped in 2010 = 009
GeorgeG is offline   Reply With Quote
Old 03-25-2009, 03:52 AM   #26
Seasonal Camper
 
GeorgeG's Avatar
 
Join Date: Dec 2008
Location: Pittsburgh
Posts: 433
Send a message via Yahoo to GeorgeG
I just called surflo and talked to a tech and told him what the pump was doing. I told him I had it disconnected from the trailer and it would pump for about 5 min and then go to a trickle and I was doing this with waterin a bucket. He told me that the pump needs replaced that it is going bad. He was going to ship out a replacement toa dealer near me and I told him that I am taking the trailer back to CR for other work and he gave me his name and extension and said to have them replace the pump and they can call him with any questions on it.



Very nice person and helpful.
__________________
George

Nights camped in 2010 = 009
GeorgeG is offline   Reply With Quote
Old 03-25-2009, 04:34 AM   #27
Site Team
 
Join Date: Dec 2007
Location: WI.
Posts: 9,160
George:
You probably fried it by running it to long empty.
Reason I say that is---been there done that.


Lloyd is offline   Reply With Quote
Old 03-25-2009, 04:46 AM   #28
Seasonal Camper
 
GeorgeG's Avatar
 
Join Date: Dec 2008
Location: Pittsburgh
Posts: 433
Send a message via Yahoo to GeorgeG
Quote:
Originally Posted by Old Farmer
George:
You probably fried it by running it to long empty.
Reason I say that is---been there done that.


I kind of figured that. Now the next question is, is there still a restriction from the tank or is there just not enough suction with the pump going bad. It did work for about 5 minutes!Guess I'll find out when CR puts in the new pump.
__________________
George

Nights camped in 2010 = 009
GeorgeG is offline   Reply With Quote
Old 03-25-2009, 05:09 AM   #29
Seasonal Camper
 
scott's Avatar
 
Join Date: Aug 2006
Location: Indiana
Posts: 336
Wow, what an ordeal. I had this happen a couple of years ago and I thought it was the pick up hose in the tank floating to the top when I filled the tank. I was able to turn the antifreeze valve at the pump half way and blow into the hose. This worked so I figured the pump was air locked. My guess with your description is that you had sediment (plastic) in the tank and/or line it finally made it's way to the pump and plugged it up. I bet if you was to take the pump apart you would find it full of junk. In the end I would suggest putting an in line filter before the pump to catch this kind of thing. Hope it all turns out.
__________________
Scott
'05 2500 HD
'04 PF30CK
https://i95.photobucket.com/albums/l1...04/TheRig3.jpg
scott is offline   Reply With Quote
Old 03-25-2009, 05:12 AM   #30
Seasonal Camper
 
GeorgeG's Avatar
 
Join Date: Dec 2008
Location: Pittsburgh
Posts: 433
Send a message via Yahoo to GeorgeG
I didn't even start to drink before I quit working on it today!!
__________________
George

Nights camped in 2010 = 009
GeorgeG is offline   Reply With Quote
Old 03-25-2009, 09:51 AM   #31
Family Vacation Member
 
buddhabob1's Avatar
 
Join Date: Jan 2009
Location: Van Wert, OHIO
Posts: 194
Ya need to get that kegermiester installed sounds like you need it Wow i hope i dont have that many problems!!!!
__________________
2004 Chevy 3500 LT 4x4

Duramax,allison.etc.

2009 30SK Patriot edition

Pullrite 20.5k Super Fifth

https://i494.photobucket.com/albums/r...b1/NewSpot.jpg
buddhabob1 is offline   Reply With Quote
Old 03-25-2009, 10:05 AM   #32
Seasonal Camper
 
GeorgeG's Avatar
 
Join Date: Dec 2008
Location: Pittsburgh
Posts: 433
Send a message via Yahoo to GeorgeG
See my 5ver was built on a Friday before a Monday holiday!! Everyone was thinking about partying.
__________________
George

Nights camped in 2010 = 009
GeorgeG is offline   Reply With Quote
Old 03-25-2009, 10:55 AM   #33
Full Time Camper
 
Chrisnan23's Avatar
 
Join Date: Apr 2006
Location: KS
Posts: 863
Actually when they put the fittings on they drill spin them and sometimes it leaves particles.
__________________
https://i139.photobucket.com/albums/q...DSCN1626-1.jpgChris and Nan Nelson Molly the wild child Niya the half pint beagle
29RK we love 2006 F250SD with Triton V10

Chrisnan23 is offline   Reply With Quote
Old 03-25-2009, 11:47 AM   #34
Family Vacation Member
 
cruzr4-2's Avatar
 
Join Date: Jan 2006
Location: Washington
Posts: 144
I,m with Chris on this one. I think the piece from a hole they drilled for the fittings fell inside and has found your pick up tube. If you have a compressor maybe you could blow back through the pickup tube to dislodge it. I would also have the fill cap off so you don't pressurize your tank. You still may have to drop the tank to remove the piece, if thats what it is.

Good luck

Dennis
__________________
Dennis & Sharon
2019 Sierra Denali CC
2006 Cruiser CF29RE

cruzr4-2 is offline   Reply With Quote
Old 03-25-2009, 11:50 AM   #35
Seasonal Camper
 
GeorgeG's Avatar
 
Join Date: Dec 2008
Location: Pittsburgh
Posts: 433
Send a message via Yahoo to GeorgeG
Quote:
Originally Posted by cruzr4-2
You still may have to drop the tank to remove the piece, if thats what it is.

Good luck

Dennis


Not me dropping the tank!! CR will be next month!!
__________________
George

Nights camped in 2010 = 009
GeorgeG is offline   Reply With Quote
Old 03-25-2009, 11:57 AM   #36
Full Time Camper
 
mwebber78's Avatar
 
Join Date: Jun 2008
Location: Maine
Posts: 1,250
Send a message via Yahoo to mwebber78
Did you get a firm date at the factory for repair George?



I will be there the 3rd week of April.
__________________
Mike
2013 Jayco Eagle 334RBTS
Crossroads Forum Lurker
mwebber78 is offline   Reply With Quote
Old 03-25-2009, 12:01 PM   #37
Seasonal Camper
 
GeorgeG's Avatar
 
Join Date: Dec 2008
Location: Pittsburgh
Posts: 433
Send a message via Yahoo to GeorgeG
Yes, Randy has me in for April 14th. He said that he is going to put 3 techs on my 5ver that day. He wants to try and get everything done in one day. Since I emailed Randy my list, I have added 2 or 3 more items.
__________________
George

Nights camped in 2010 = 009
GeorgeG is offline   Reply With Quote
Old 03-25-2009, 12:03 PM   #38
Full Time Camper
 
mwebber78's Avatar
 
Join Date: Jun 2008
Location: Maine
Posts: 1,250
Send a message via Yahoo to mwebber78
I'll be there the 23rd. I can't wait for the factory tours in the Elkhart area, I would love to see how everyone does their construction.



__________________
Mike
2013 Jayco Eagle 334RBTS
Crossroads Forum Lurker
mwebber78 is offline   Reply With Quote
Old 03-25-2009, 12:07 PM   #39
Seasonal Camper
 
GeorgeG's Avatar
 
Join Date: Dec 2008
Location: Pittsburgh
Posts: 433
Send a message via Yahoo to GeorgeG
I'm patiently waiting for both, to see the factory and get the 5ver repaired.
__________________
George

Nights camped in 2010 = 009
GeorgeG is offline   Reply With Quote
Old 03-25-2009, 12:58 PM   #40
Family Vacation Member
 
Cajun TBoy's Avatar
 
Join Date: Jan 2009
Location: Louisiana
Posts: 129
George,sorry about your latest problem. Know the feeling I find myself asking that same question. My pump ran then burnt the fuse. now Its also noise. I just found hair line cracks in the gel coat next to the door Not happy either. I have spoken to Randy butnot feeling like he's concerned. I would love to send this one back to CR.
__________________
Brent & Tina
2013 Dodge Ram Big Horn 3500 DRW, CC, CTD w/ TruXedo low pro
2009 Kingston KF33SK
2008 Club Cart Precedent
https://i128.photobucket.com/albums/p...olfcart2-1.jpg
Cajun TBoy is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 06:02 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
×