Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-03-2018, 07:45 PM   #1
PLW
New Camper
 
Join Date: Sep 2014
Location: Ontario
Posts: 6
Zinger 5th wheel electrical problem

Have 31ft.rear kitchen model and the outside receptacle and the receptacle in rear of kitchen are not working. GFCI over the sink kept tripping so we replaced it but the new one does the same. We replaced it with a regular receptacle to see what would happen and it works but the other 2 still do not work. The fuses and breakers are all ok.
Does anyone have access to an electrical schematic for this model or know what might be the problem.
PLW is offline   Reply With Quote
Old 07-04-2018, 05:59 AM   #2
Seasonal Camper
 
Join Date: Mar 2015
Location: NC
Posts: 274
Had a similar problem where plugging into any 20 amp CGFI on the house popped it but regular connection was fine. Also had slide receptacles not working. Never got definitive answers or figured out exactly what was going on but suspect there is a connection (or failed connection, lol).

I did discover through exploratory surgery that receptacles and wire connectors in these units are quick connects which can fail totally or intermittently but look OK. There are also connection boxes in odd and nearly impossible to get to locations.

I'm looking forward to more group wisdom on this thread. Sorry I don't have an easy answer.
__________________
2015 Crossroads Cruiser Aire CAF27RL, 2018 F250 diesel crewcab SRW 4WD short bed, Trailer Saver hitch with Reese adapter on Ford OEM underbed 5th wheel connector.
stormseeker is offline   Reply With Quote
Old 10-02-2019, 07:06 AM   #3
PLW
New Camper
 
Join Date: Sep 2014
Location: Ontario
Posts: 6
We finally diagnosed the problem. If you are inside standing looking at back of trailer we have left to right, stove, fridge and then cabinets at corner. On the right wall between those cabinets and slide for table and couch, low on wall there is an electrical access cover. We opened that up and one wire was not attached properly. Fixed that and now everything works again
PLW is offline   Reply With Quote
Old 10-02-2019, 07:21 AM   #4
Site Team
 
Join Date: Jun 2015
Location: mo
Posts: 853
Thank you for posting the solution to your problem. It may give someone else with a similar problem a starting place. Some post a question but we never know the solution so thanks again!
__________________
2005 Cruiser 29CK
2008 GMC 2500hd 4x4
Crew cab Long bed 6.0 gas
4.10 gear ratio
dagst1 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 05:16 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×