Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-18-2020, 02:41 PM   #1
Seasonal Camper
 
Biggles607's Avatar
 
Join Date: Jan 2017
Location: Florida
Posts: 328
Firefox Browser v 72.0.1

My web browser, Mozilla Firefox was recently upgraded to version 72.0.1.

I've used Firefox for a dozen years, maybe more with no issues.

Since the upgrade I'm having issues loading content on ONLY this site.

I log in like normal with my ID and password, then 90% of times I get the error message.

'The page isn't redirecting properly"
An error occurred during a connection to www.crossroadsowners.com.
This problem can sometimes be caused by disabling or refusing to accept cookies.
Try again.

Sometimes, after clicking try again several times it will allow me to go the the next page, but then the exact same thing happens when I select say a topic to view....

I've tried everything.

To get this message to you I've resorted to using 'Internet Explorer' which I'm not a fan of but it got me here.

I have noticed that in the URL bar, when I try to log in my preferred way with 'Firefox' there's a grey padlock with a red bar running through it indicating an insecure site, could it be my updated browser is preventing me from exposing myself to a vulnerable site?

I hope someone can help please.
__________________
Biggles
2015 Toyota Tundra Dbl Cab 5.7 V8
2017 Zinger Z-1 291RL "Harvey'
Biggles607 is offline   Reply With Quote
Old 01-18-2020, 04:46 PM   #2
Site Team
 
mark5w's Avatar
 
Join Date: Sep 2012
Location: PA
Posts: 4,886
Even though the website does not show HTTPS, when you put the arrow on the log in tab, HTTPS shows up on the bottom left corner of your screen. So the website is secure.


You can try using the new Edge Chromium browser that is now available.
__________________
Mark & Susan
Lehighton, Pennsylvania

'13 Cruiser Patriot 335SS - '13 Ford F150 SCREW - PullRite Superslide - Roadmaster Active Suspension
Member - "Northeast Adventures RV Rally Group" & "Mason-Dixon Bunch"
mark5w is offline   Reply With Quote
Old 01-18-2020, 05:44 PM   #3
Seasonal Camper
 
Biggles607's Avatar
 
Join Date: Jan 2017
Location: Florida
Posts: 328
Thanks Mark, that the site is secure is a relief.


However, Is anyone else experiencing the same problem as me, is mine a known anomaly with Firefox 72.0.1? if so I'll chase 'them' for a fix.


Thanx again.
__________________
Biggles
2015 Toyota Tundra Dbl Cab 5.7 V8
2017 Zinger Z-1 291RL "Harvey'
Biggles607 is offline   Reply With Quote
Old 01-18-2020, 06:00 PM   #4
Site Team
 
mark5w's Avatar
 
Join Date: Sep 2012
Location: PA
Posts: 4,886
Fyi, I'm running the same version of Firefox as you are and no problems. Try cleaning your cache and registry. I use Wise registry cleaner.
__________________
Mark & Susan
Lehighton, Pennsylvania

'13 Cruiser Patriot 335SS - '13 Ford F150 SCREW - PullRite Superslide - Roadmaster Active Suspension
Member - "Northeast Adventures RV Rally Group" & "Mason-Dixon Bunch"
mark5w is offline   Reply With Quote
Old 01-18-2020, 06:33 PM   #5
Site Team
 
Join Date: Dec 2007
Location: WI.
Posts: 7,927
John, I'm running the same version --- 72.0.1

So far no issues, but I'm seriously thinking about trying the Edge Chromium browser.
Firefox has been known to have their issues on occasion.
__________________
2008 Cruiser CF26RK
2013 Ford Eco-Boost
Heavy duty payload - Max tow
Lloyd is offline   Reply With Quote
Old 01-19-2020, 12:11 PM   #6
Seasonal Camper
 
Biggles607's Avatar
 
Join Date: Jan 2017
Location: Florida
Posts: 328
Thanks guys,


I've cleared my cache, and cookies to no avail. I have no problem with any other sites.


It's baffling that one minute everything is smooth as silk, the next yuk!


I'm here now only via IE, I guess it'll have to suffice until I can find another fix for Firefox.
__________________
Biggles
2015 Toyota Tundra Dbl Cab 5.7 V8
2017 Zinger Z-1 291RL "Harvey'
Biggles607 is offline   Reply With Quote
Old 01-21-2020, 06:29 PM   #7
Site Team
 
Janet H's Avatar
 
Join Date: Oct 2013
Location: PNW
Posts: 659
The recent Firefox update has been a headache for many users. For some folks a reinstall of Firefox seems to help as does disabling browser add-ins. Frankly my best advice is to try chrome. The forum has not changed....
Janet H is offline   Reply With Quote
Old 01-22-2020, 08:12 PM   #8
Seasonal Camper
 
Biggles607's Avatar
 
Join Date: Jan 2017
Location: Florida
Posts: 328
It seems there is no work around for the error message I keep getting using Firefox 72.0.2 right now.

Reading through their troubleshooting guide it seems the latest security protocols they employ have a known conflict and do not play nice with older TLS systems. Whether that's the issue here I don't know, but for now I'm using IE otherwise I'd be completely incommunicado with all you fine peeps.
__________________
Biggles
2015 Toyota Tundra Dbl Cab 5.7 V8
2017 Zinger Z-1 291RL "Harvey'
Biggles607 is offline   Reply With Quote
Old 01-22-2020, 08:41 PM   #9
Site Team
 
mark5w's Avatar
 
Join Date: Sep 2012
Location: PA
Posts: 4,886
Don't use IE. It's not a very secure browser. The new Microsoft Edge is a more secure browser and it's also fast.


You could roll back to the previous Firefox to see if it helps.
__________________
Mark & Susan
Lehighton, Pennsylvania

'13 Cruiser Patriot 335SS - '13 Ford F150 SCREW - PullRite Superslide - Roadmaster Active Suspension
Member - "Northeast Adventures RV Rally Group" & "Mason-Dixon Bunch"
mark5w is offline   Reply With Quote
Old 01-23-2020, 07:12 AM   #10
Seasonal Camper
 
Biggles607's Avatar
 
Join Date: Jan 2017
Location: Florida
Posts: 328
Your right Mark, I've never been a fan of IE, but for now it lets me get on here.

If only I knew how to 'roll back' to a previous version of Firefox, I'd do it in a heartbeat. Don't I have to go to WalMart to do that ? (Sniggering..)
__________________
Biggles
2015 Toyota Tundra Dbl Cab 5.7 V8
2017 Zinger Z-1 291RL "Harvey'
Biggles607 is offline   Reply With Quote
Old 01-23-2020, 02:28 PM   #11
Weekend Camper
 
Join Date: Jun 2017
Location: TN
Posts: 43
I would echo Mark and suggest using the new Microsoft Edge Chromium browser. It is very fast and has some nice features that other browsers don't have, Privacy being one of them. You can download it from https://support.microsoft.com/en-us/...ed-on-chromium
__________________
Barry
2014 Sunset Trail Reserve 32RL
cottonakin is offline   Reply With Quote
Old 01-24-2020, 09:24 AM   #12
Site Team
 
Janet H's Avatar
 
Join Date: Oct 2013
Location: PNW
Posts: 659
Please don't use IE. It's a serious security risk for your system. Edge or chrome are better options. https://www.forbes.com/sites/daveywi.../#420dbbec3212
Janet H is offline   Reply With Quote
Old 01-27-2020, 04:34 PM   #13
Seasonal Camper
 
Biggles607's Avatar
 
Join Date: Jan 2017
Location: Florida
Posts: 328
Thanks Janet.

I downloaded and am using MS Edge..... seems OK so far.
__________________
Biggles
2015 Toyota Tundra Dbl Cab 5.7 V8
2017 Zinger Z-1 291RL "Harvey'
Biggles607 is offline   Reply With Quote
Old 02-08-2020, 04:42 AM   #14
Seasonal Camper
 
Biggles607's Avatar
 
Join Date: Jan 2017
Location: Florida
Posts: 328
FYI everyone....


So, whatever that non existent issue was that inspired me to author this thread, someone has clearly fixed it.


After downloading and using MS Edge since I last posted, I inadvertently clicked on my bookmark to this site in my unchanged, old favorite, Firefox browser v72.0.2, and guess what, everything opens flawlessly again, go figure.


Thanks to whomever sorted this.


Best regards all, and thanks for the interim fix which served me well.
__________________
Biggles
2015 Toyota Tundra Dbl Cab 5.7 V8
2017 Zinger Z-1 291RL "Harvey'
Biggles607 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Crossroads Registry

Our get away

RCAircraft

0

DurTar
Add your Crossroads RV
» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 12:32 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×