Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-08-2016, 01:28 PM   #1
New Camper
 
Join Date: Apr 2015
Location: MI
Posts: 5
I can't find the fresh water pump...

I have a 2016 Crossroads Sunset Trail Reserve 32RL. For the life of me, I cannot find the the water pump to winterize the camper. I've tried putting water in the tank and follow the sound of the pump, the pump doesn't make a sound. I have looked on the side of the bed, everyone says that is where it is, but there are no screws. I looked in the closets for an access panel, no luck. Any ideas?
saphill2 is offline   Reply With Quote
Old 10-08-2016, 03:00 PM   #2
Full Time Camper
 
woodwalker's Avatar
 
Join Date: Oct 2015
Location: ca
Posts: 526
Is it pumping water when turned on cause if it is I want one of those pumps. Every rv I have owned the pump made noise when working
__________________
2015 Redwood 36RL pushing a 2015 Denali DRW
woodwalker is offline   Reply With Quote
Old 10-08-2016, 04:02 PM   #3
Seasonal Camper
 
Join Date: Jul 2009
Location: Idaho
Posts: 377
Quote:
Originally Posted by woodwalker View Post
Is it pumping water when turned on cause if it is I want one of those pumps. Every rv I have owned the pump made noise when working
X2. All trailers I have had made a lot of noise.

When you find it let us know the make and model of the pump.

I would consider replacing mine.
rcflyer is offline   Reply With Quote
Old 10-08-2016, 04:57 PM   #4
Weekend Camper
 
Join Date: Mar 2016
Location: Ny
Posts: 66
Can't find water pump.

This may or may not help.
I have a different year and model. It's likely closer to fresh water tank, shorter run for drawing water up to system.
Mine was well hidden behind a removable panel under the stove. Easily removed four screws and there it was. Good luck.
__________________
Bowhunter and Linda
2012 Zinger ZT 26BHS
2015 Silverado 2500 HD 4x4 6.0 Gasser
1995 Ram 1500 4x4 5.4 Gasser/Hunt Truck (cherry)
Bowhunter is offline   Reply With Quote
Old 10-09-2016, 10:09 AM   #5
Weekend Camper
 
Join Date: Oct 2014
Location: Ontario
Posts: 35
To winterize my /13 Cruiser I remove the flimsy cosmetic panel that is found under the kitchen sink. Doing that will expose everything needed to winterize e.g.; hot water tank c/w bypass kit and 2 way valve used to pump antifreeze directly from the store antifreeze container through the system (as opposed to pumping from the cold water tank).

Hope this helps.

Fuzzdr
__________________
fuzzdr
Cruiser CF31LK 2014; F-350 Crew Diesel SRW 2015
fuzzdr is offline   Reply With Quote
Old 10-09-2016, 12:17 PM   #6
New Camper
 
Join Date: Apr 2015
Location: MI
Posts: 5
Quote:
Originally Posted by Bowhunter View Post
This may or may not help.
I have a different year and model. It's likely closer to fresh water tank, shorter run for drawing water up to system.
Mine was well hidden behind a removable panel under the stove. Easily removed four screws and there it was. Good luck.
Thank you. I've removed everywhere I can find screws with no success. When I turn it on it makes no noise so I'm still unable to locate it. I'm hoping someone with the same year and model will be able to help.
saphill2 is offline   Reply With Quote
Old 10-09-2016, 12:19 PM   #7
New Camper
 
Join Date: Apr 2015
Location: MI
Posts: 5
Quote:
Originally Posted by fuzzdr View Post
To winterize my /13 Cruiser I remove the flimsy cosmetic panel that is found under the kitchen sink. Doing that will expose everything needed to winterize e.g.; hot water tank c/w bypass kit and 2 way valve used to pump antifreeze directly from the store antifreeze container through the system (as opposed to pumping from the cold water tank).

Hope this helps.

Fuzzdr
Thank you. I've found the hot water heater and the pump is not next to it. It's not beside the bed either. Still searching.
saphill2 is offline   Reply With Quote
Old 10-09-2016, 12:22 PM   #8
New Camper
 
Join Date: Apr 2015
Location: MI
Posts: 5
Quote:
Originally Posted by woodwalker View Post
Is it pumping water when turned on cause if it is I want one of those pumps. Every rv I have owned the pump made noise when working

It doea not pump any water and makes no noise. It was winterized last year the first year we had it from where we bought it. They couldn't remember where it was. I'm hoping someone here will be to help.
saphill2 is offline   Reply With Quote
Old 10-09-2016, 01:29 PM   #9
Full Time Camper
 
woodwalker's Avatar
 
Join Date: Oct 2015
Location: ca
Posts: 526
Quote:
Originally Posted by saphill2 View Post
It doea not pump any water and makes no noise. It was winterized last year the first year we had it from where we bought it. They couldn't remember where it was. I'm hoping someone here will be to help.
Do you have water in fresh tank. I would check all fuses as that may be why it's not pumping.
__________________
2015 Redwood 36RL pushing a 2015 Denali DRW
woodwalker is offline   Reply With Quote
Old 10-09-2016, 02:46 PM   #10
Site Team
 
mark5w's Avatar
 
Join Date: Sep 2012
Location: PA
Posts: 4,716
If you have a drawer on your island, remove the bottom drawer and your winterizing setup should be there,
__________________
Mark & Susan
Lehighton, Pennsylvania

'13 Cruiser Patriot 335SS - '13 Ford F150 SCREW - PullRite Superslide - Roadmaster Active Suspension
Member - "Northeast Adventures RV Rally Group" & "Mason-Dixon Bunch"
mark5w is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 10:03 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.