Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-13-2014, 05:35 AM   #1
Weekend Camper
 
Join Date: Sep 2012
Location: Georgia
Posts: 17
Need Help

After the last camping trip we cleaned the our 32OB and parked it under the shelter, went out Monday to check it out and no lights, I checked the Battery and it was dead, 0 volts on meter. hooked up shore power still no lights, put in a new battery heard a clicking sound under a black cover mounted behind the battery, I checked breakers in side the trailer none were tripped. What do i need to check now.
__________________
2013 Zinger 32QB aluminum side
D Haire is offline   Reply With Quote
Old 05-13-2014, 06:17 AM   #2
Seasonal Camper
 
hondavalk's Avatar
 
Join Date: Feb 2013
Location: ohio
Posts: 323
Are you sure you didn't reverse the battery leads?
__________________
hondavalk
2008 Tundra 5.7L
2013 ST29SS
Reese DC
hondavalk is offline   Reply With Quote
Old 05-13-2014, 07:00 AM   #3
Family Vacation Member
 
Gcross1468's Avatar
 
Join Date: May 2013
Location: Alabama
Posts: 163
Could be 2 things from the sound of it. Leads hooked up backwards or a dead short caused by a bad ground on the frame. Follow the negative lead back to where it grounds and make sure it's cleaned of any corrosion.
__________________

**WAS**2013 Sunset Trail Reserve SF32RL
**WAS**2011 Dodge 1500 Outdoorsman
**NOW** 2015 RAM 2500 6.7L CUMMINS TURBO DIESEL
Gcross1468 is offline   Reply With Quote
Old 05-13-2014, 07:31 AM   #4
Weekend Camper
 
Join Date: Sep 2012
Location: Georgia
Posts: 17
thanks guys for the help, Battery leads are hooked up right, will check on ground wire when i get home today.
__________________
2013 Zinger 32QB aluminum side
D Haire is offline   Reply With Quote
Old 05-13-2014, 07:45 AM   #5
Full Time Camper
 
harley's Avatar
 
Join Date: Aug 2012
Location: Belle River , Ontario
Posts: 1,626
just an FYI for everyone hooking up batteries after the winter, use red marker or nail polish and paint the ends of the '+' wire red. and also paint red near the '+' terminal of the battery.
__________________


It was a rainy few days at Algonquin Prov park...tarps kept us dry.
Wayne --Belle River (Windsor), Ontario
2013 Sunset Trail Reserve 25RB..
2015 White Chev Silverado 2500HD 4x4 (6.0 l gasser)
2003 Mountain Star 890SBRX Truck Camper
harley is offline   Reply With Quote
Old 05-13-2014, 07:57 AM   #6
Site Team
 
Join Date: Dec 2007
Location: WI.
Posts: 7,634
Good point Harley!
I have red tape on my + cable.
__________________
2008 Cruiser CF26RK
2013 Ford Eco-Boost
Heavy duty payload - Max tow
Lloyd is offline   Reply With Quote
Old 05-13-2014, 08:19 AM   #7
Full Time Camper
 
OhioMark's Avatar
 
Join Date: Mar 2013
Location: United states of america
Posts: 1,540
First, if you the ability I'd connect a car charger to the battery. If the power comes on, its either the converter or somewhere in between.

Next, I'd pull the battery and try bench charging overnight and check the voltage the next day. Most battery chargers now have meters so you'll know if it is taking the charge.

When I had a dead battery even with shorepower, it ended up being the converter. Luckily for me, it was a short not the actual converter.

After my converter experience (while camping) I now have a smart charger in my onboard tool kit. It's really neat because it has a mode that checks the alternator. I used it to determine the battery wasn't getting a charge from the converter.
__________________

2017 Ford F350 Super Duty 6.7 King Ranch Crew
2016 Crossroads Sunset Trail Grand Reserve 32BH
OhioMark is offline   Reply With Quote
Old 05-13-2014, 10:08 AM   #8
Full Time Camper
 
ewbldavis's Avatar
 
Join Date: Apr 2011
Location: Canton, OH
Posts: 936
If you don't have lights when hooked to shore power, start with fuses. You should still be able to use 12V fixtures when plugged in (even if battery is removed). Then what they said
__________________
Eddy & Brenda
Canton, OH
2015 Silverado HD 6.0L
2014 Zinger 32QB
ewbldavis is offline   Reply With Quote
Old 05-14-2014, 07:18 AM   #9
Weekend Camper
 
Join Date: Sep 2012
Location: Georgia
Posts: 17
charged the Battery, it now has a full charge. put it back in the camper and found that a small fan had been left on in the back bedroom, i think this is what killed the Battery. everything now works. Thanks for all the Help Guys.
__________________
2013 Zinger 32QB aluminum side
D Haire is offline   Reply With Quote
Old 05-14-2014, 07:38 AM   #10
Family Vacation Member
 
Gcross1468's Avatar
 
Join Date: May 2013
Location: Alabama
Posts: 163
Glad you got it solved! Nothing worse than trying to troubleshoot an electrical problem : )
__________________

**WAS**2013 Sunset Trail Reserve SF32RL
**WAS**2011 Dodge 1500 Outdoorsman
**NOW** 2015 RAM 2500 6.7L CUMMINS TURBO DIESEL
Gcross1468 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 08:25 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.