Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-24-2015, 07:40 AM   #1
New Camper
 
Join Date: May 2015
Location: Ontario
Posts: 3
Furnace issues

Bought our 2015 270bh in the fall. Did not get to make a camping trip with it then but did spend some quality time in the driveway. Due to the weather we had the furance on and had no issues. Since we got it out of storage this spring we have found that the furnace does not work correctly. Will run a few cycles great and then after that the fan/blower runs but does not send out hot air and will shut off after about 1 minute. Any help with this would be geat. The dealer we bought it off of is about 1-1/2 hours away and really dont feel like doing the drive back and forth and having to have down time away from trailer at this time of year!
Thanks in advance!
Selena is offline   Reply With Quote
Old 06-24-2015, 08:06 AM   #2
Full Time Camper
 
Loneoak's Avatar
 
Join Date: Sep 2013
Location: Winchester, ON
Posts: 1,177
Is the propane on? If it is, it sounds to me like it is not lighting.

Sometimes insects like wasps make a nest in the furnace and screw things up. The hole to get in is fairly large. We caught them making a nest near the entrance of the vent on the side of the trailer. We removed the nest and put a special screen over the hole.
__________________

2012 Cruiser Sahara 330SS
2015 F250 Super Duty diesel
Loneoak is offline   Reply With Quote
Old 06-24-2015, 08:20 AM   #3
New Camper
 
Join Date: May 2015
Location: Ontario
Posts: 3
Yes the propane is on! Even tried switching tanks to see if maybe issue withnone of the lines. No insect issues. It runs for 1 or 2 cycles great and then wont ignite so that fan/blower sends out the hot air causing it to shut off after about 1 minute!
Selena is offline   Reply With Quote
Old 06-24-2015, 09:28 AM   #4
Full Time Camper
 
Stan's Avatar
 
Join Date: Apr 2006
Location: Oak Harbor, WA
Posts: 1,994
Could be several different causes. Bad temp switch, thermostat or possibly restriction in the air flow causing it to overheat and shutdown. Do you have good airflow out ALL registers? Since it is under warranty, I would bite the bullet and schedule a dealer appt.
__________________
Stan and Terri
Oak Harbor, WA
2008 Chevy 2500HD D/A
2007 Cruiser CF30SK
Glide Ride Pin Box
Reese 16K Slider
Stan is offline   Reply With Quote
Old 06-28-2015, 08:42 PM   #5
Weekend Camper
 
manty's Avatar
 
Join Date: Feb 2011
Location: Minneapolis
Posts: 13
Make sure the fan setting is on "auto". If it is on "hi" or "low" the furnace will not come on (if it's a Dometic).
manty is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 11:20 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×