Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-27-2014, 05:43 PM   #1
Weekend Camper
 
Tommy's Avatar
 
Join Date: Oct 2013
Location: Covington
Posts: 13
Need Help

I also crossed wired battery, I have since then replaced (1) 15 amp fuse for radio and front bed lights, all (5) 20 amp reverse polar fuses, but I can not get my AC/Heat thermostat to kick on at all. everything seems to be working properly except this. I even took out circuit breaker for the unit and hot water heater as they were connect and replaced it and nothing. I am at wits end, I am also at Enid, MS Persimmon Hill CG if anyone's close. LOL let me tell you I am spent!!!!! its our second time in camper. 270BH.
I will hang up and listen.
Tommy is offline   Reply With Quote
Old 03-27-2014, 06:07 PM   #2
Site Team
 
mark5w's Avatar
 
Join Date: Sep 2012
Location: PA
Posts: 4,750
Check the thermostat wire where it connects to the furnace and AC. Sounds to me like the white wire came loose, because that will cause both the furnace and the AC to fail. Some heating/Air Conditioning controls have a small glass fuse on the circuit board.

Finally, you could have fried the thermostat.

Good luck, I'm sure some others will chime in and help.
__________________
Mark & Susan
Lehighton, Pennsylvania

'13 Cruiser Patriot 335SS - '13 Ford F150 SCREW - PullRite Superslide - Roadmaster Active Suspension
Member - "Northeast Adventures RV Rally Group" & "Mason-Dixon Bunch"
mark5w is offline   Reply With Quote
Old 03-28-2014, 05:21 PM   #3
Weekend Camper
 
Tommy's Avatar
 
Join Date: Oct 2013
Location: Covington
Posts: 13
One pack of $1.98 2 amp fuses for the thermostat fixed the problem. Thanks for the input I had no idea about the fuse in the thermostat.
Tommy is offline   Reply With Quote
Old 03-29-2014, 07:18 AM   #4
Full Time Camper
 
Tim D's Avatar
 
Join Date: May 2013
Location: So IL
Posts: 1,811
Glad that fixed it. And it was cheap and simple.
__________________

Tim
13 ST25RB
08 F-250 SC 6.8L XLT 4x4
Tim D is offline   Reply With Quote
Old 03-29-2014, 07:31 AM   #5
Weekend Camper
 
Tommy's Avatar
 
Join Date: Oct 2013
Location: Covington
Posts: 13
No kidding, not only that got the wife off my back as well. Just glad it wasn't anything major.
Tommy is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 02:28 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×