Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-09-2016, 07:50 PM   #1
Weekend Camper
 
akaustin's Avatar
 
Join Date: May 2015
Location: Northwest Territories
Posts: 30
No power to tv and stereo

I connected the battery incorrectly, with reversed polarity. Had to swap the 4 20amp fuses out and now everything is working except for the TV and stereo. They are on their own circuit along with the antenna and their fuse is OK but still no power. Anyone have any ideas what is going on?
akaustin is offline   Reply With Quote
Old 05-11-2016, 10:52 AM   #2
Family Vacation Member
 
RoadDog66's Avatar
 
Join Date: Jun 2013
Location:
Posts: 188
Did you check the GFI buttons on the outlets? Might be wired to one of those. Weirder things have happened.
__________________
'14 Sunset Trail 290QB
Towed by a '15 Ram 2500 6.4 Hemi 4x4 CC
Equalizer 1200/12K (just because I still have it)
RoadDog66 is offline   Reply With Quote
Old 05-11-2016, 12:50 PM   #3
Family Vacation Member
 
CampMacKay's Avatar
 
Join Date: Sep 2011
Location: Ontario
Posts: 125
Check for a fuse on the back of the stereo and on the antena booster. If there, they will be small.
__________________
🇨🇦 Scott & Janie 🇨🇦
2004 Dodge RAM 2500 CTD (slightly tweaked)
2011 Cruiser 31RK
Cooper the Golden Retriever, and
Sam the black lab.
CampMacKay is offline   Reply With Quote
Old 05-11-2016, 12:52 PM   #4
Full Time Camper
 
cw3jason's Avatar
 
Join Date: Feb 2013
Location: Connecticut
Posts: 688
The stereo will have a separate in line fuse behind the unit or in the back of the stereo. as for the TV, I am not sure. it should run on AC voltage, and that should be ok, but it could have gotten zapped. try unplugging it and let it rest. My Sunset Trail had a TV that had to be unplugged for an extended period of time to reset it. I learned to just leave it unplugged until I was ready to use it, then unplug it again before I disconnected shore power for travel. check for power at the plug and then plug it back in. If you have power at the outlet, but TV still does not work, it probably got zapped.
__________________

Jason & Wendy
2014 Ford F-350 Lariat 6.7L PSD
2015 Keystone Montana 3711FL
B&W Patriot 16K Fifth Wheel Hitch
cw3jason is offline   Reply With Quote
Old 05-11-2016, 02:18 PM   #5
Full Time Camper
 
woodwalker's Avatar
 
Join Date: Oct 2015
Location: ca
Posts: 526
The tv should not be affected hooking batteries up backwards. It runs on 120v. Unless it was plugged into an invertor fed by the batteries.the stereo should have an in line fuse to protect it and it may have blown
__________________
2015 Redwood 36RL pushing a 2015 Denali DRW
woodwalker is offline   Reply With Quote
Old 05-11-2016, 03:36 PM   #6
Site Team
 
mark5w's Avatar
 
Join Date: Sep 2012
Location: PA
Posts: 4,723
run an extension from a working outlet to see if the tv works. Then you'll know the tv electric circuit is at fault or not.
__________________
Mark & Susan
Lehighton, Pennsylvania

'13 Cruiser Patriot 335SS - '13 Ford F150 SCREW - PullRite Superslide - Roadmaster Active Suspension
Member - "Northeast Adventures RV Rally Group" & "Mason-Dixon Bunch"
mark5w is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 11:04 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.