View Poll Results: Problem with a swinger slide on 30 foot dinning room slide
No problem 15 51.72%
Had one problem 8 27.59%
Had it to the dealer more then once 6 20.69%
Voters: 29. You may not vote on this poll

Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-29-2012, 10:32 AM   #1
Weekend Camper
 
Djkell001's Avatar
 
Join Date: Jul 2012
Location: PA
Posts: 35
Does anyone have a 30re that has expiemced problems wit the slide out. My unit is six months old and I have taken twice once for a complete burnout of the swinger system. Now after a complete replacement and only sliding it out 7 or 8 times it again does not go out straight. This is the first sign of problems. Next it either will bind and not come in or not go out. I was just wondering if I am the only one with this issue.
Djkell001 is offline   Reply With Quote
Old 07-29-2012, 01:18 PM   #2
Pnr
Family Vacation Member
 
Join Date: Feb 2012
Location: Oklahoma
Posts: 131
I had that problem and found if I keep the gear tracks lubed, it seems to have solved the problem.

Paul
Pnr is offline   Reply With Quote
Old 07-31-2012, 12:48 AM   #3
Full Time Camper
 
NorskeNY's Avatar
 
Join Date: Oct 2011
Location: Upstate NY
Posts: 874
We had problems with our </span>SCHWINTEK system prior to delivery and a few times this summer. The front motor of the slide seems to torque out early. Before we took delivery they must have made an adjustment of the torqe setting. Did not have any problems again until our last outing. The front motor seemed to torque out early. I ran the slide out a little and it straightened itself out.

I have applied lube to the rails too to see if that helps with the bed slide going in and out. part of the problem I think is the fact that the front of the bed drags on the floor and adds friction to the in and out movement. May try to put some thin teflon under the front and see if that helps.


__________________
Bob and Pat

2012 Cruiser Patriot CF335SS.

2011 Silverado 3500HD LTZ CCLB Duramax SRW 4X4

http://i1193.photobucket.com/albums/...ailerKeuka.jpg
NorskeNY is offline   Reply With Quote
Old 07-31-2012, 12:08 PM   #4
Weekend Camper
 
Djkell001's Avatar
 
Join Date: Jul 2012
Location: PA
Posts: 35
I dropped my unit off tonight at the dealer. What he told me is they are seeing that the roms are not resting on the rollers. This causes the load to be carried by the motors and tracks. I told him don't call me until you have put the room out at 20 times without an issue. I am optimistic that they can fix it. I will post what they did to fix the problem, since I am not picking it up to it is fixed.
Djkell001 is offline   Reply With Quote
Old 08-07-2012, 02:46 PM   #5
New Camper
 
Big German's Avatar
 
Join Date: Feb 2010
Location:
Posts: 3
In my opinion, the Swintek system is the biggest piece of garbage on the market. And the warranty provided by Crossroads and Lippert is a disgrace. I'm into repairs on the Swintek system installed on my 2010 Sunset Trail for over $2000 thus far and it still isn't fixed properly. I believe the root of the problem is lousy engineering (only one roller was installed when there should have been five) coupled with shoddy workmanship (bent, misaligned, or missing screws abound) and even more incompetent dealers who are supposed to support the product. I'm in the middle of selling my Crossroads Sunset Trail and moving to another manufacturer. My biggest complaint is with Lippert who designed the garbage and Crossroads who do not stand behind their product when obvious design flaws, not wear and tear,necessitate major repairs.





BE AWARE ALL SUNSET TRAILER OWNERS, check the rollers under your slide to ensure the slide is sitting on at least five rollers, and not just one as was provided in my lemon.
Big German is offline   Reply With Quote
Old 08-07-2012, 11:28 PM   #6
Weekend Camper
 
Trini's Avatar
 
Join Date: Mar 2012
Location: Brampton On
Posts: 65
we had problem with the slide on the 2012 30 RE two days after we bought it, the wires for the motor burnt out they repair it now when it sliding in and out it goes off set it don't move even and nothing they could do about it.



Trini is offline   Reply With Quote
Old 08-08-2012, 01:35 AM   #7
Full Time Camper
 
Join Date: Nov 2006
Location: Bradley, Il
Posts: 1,018




Sorry to hear of all these problems with the Swintek slide system. Our 2010 Cruiser has the old style actuator and rack and pinion style mechanism. Glad we don't have the Swintek. Hope Crossroads goes back to the "old" style before they loose a lot of customers.
__________________
Dale & Carol
Bradley, Il
2007 F-250
2010 CF30SK Patriot
2007 CF30SK
dalemac377 is offline   Reply With Quote
Old 08-08-2012, 03:17 AM   #8
Full Time Camper
 
tator447's Avatar
 
Join Date: Nov 2011
Location: WI
Posts: 896
Send a message via MSN to tator447




Forgive me is I sound naive, but is it not true there are not that many manufacturer's of these slideouts? So, don't other products use Lippert and Shwintek as well. JMHO.

Jim
__________________

Jim & Linda Tator
Watertown, WI
2013 Crusier CF34SS GMC 3500 8.1L Dually
154 nights in 2013 - 4,370 miles
178 nights in 2014 - 5,082 miles
365 nights in 2015 - 6,040 miles
tator447 is offline   Reply With Quote
Old 08-09-2012, 11:11 AM   #9
Weekend Camper
 
Djkell001's Avatar
 
Join Date: Jul 2012
Location: PA
Posts: 35
Yes there are quite a few manufacturers that use Swintek ,when it works it is like sliced bread..
Djkell001 is offline   Reply With Quote
Old 08-17-2012, 07:43 AM   #10
Weekend Camper
 
Djkell001's Avatar
 
Join Date: Jul 2012
Location: PA
Posts: 35
Well the dealer has tried to adjust it . Apparently one side was a half inch off the rollers when they adjusted to touch the rollers it bound in the opening. They are going back to the factory but it appears the opening is not square based on the measurements they took and the tolerance is too close. The dealer is now saying they will have to take the room out and correct the opening. Which will take a couple weeks to complete. They have already had the trailer for a total of 6 weeks since I bought it. I was lucky I was able to take one long trip and 2 short trips since I bought it. The dealer also told me they have a another unit that they have to do the same process to.



Djkell001 is offline   Reply With Quote
Old 08-22-2012, 11:10 AM   #11
Weekend Camper
 
Djkell001's Avatar
 
Join Date: Jul 2012
Location: PA
Posts: 35
Looks like the camper is going back to the factory for repairs.
Djkell001 is offline   Reply With Quote
Old 08-22-2012, 11:24 AM   #12
Full Time Camper
 
NorskeNY's Avatar
 
Join Date: Oct 2011
Location: Upstate NY
Posts: 874


Quote:
Originally Posted by Djkell001
Looks like the camper is going back to the factory for repairs.

Is the dealer towing it to the factory?
__________________
Bob and Pat

2012 Cruiser Patriot CF335SS.

2011 Silverado 3500HD LTZ CCLB Duramax SRW 4X4

http://i1193.photobucket.com/albums/...ailerKeuka.jpg
NorskeNY is offline   Reply With Quote
Old 08-23-2012, 08:20 AM   #13
Weekend Camper
 
Djkell001's Avatar
 
Join Date: Jul 2012
Location: PA
Posts: 35
No the factory is Having it picked
up I assume on a trailer.
Djkell001 is offline   Reply With Quote
Old 08-24-2012, 11:35 AM   #14
Weekend Camper
 
Join Date: Aug 2012
Location:
Posts: 16




Ditto to all you have said. I'm trying to unload this piece of garbage. The unit is two and a half months old and now is worth only 66% of what I paid for it.
__________________
Ray
Crant is offline   Reply With Quote
Old 08-24-2012, 11:45 AM   #15
Weekend Camper
 
Join Date: Feb 2012
Location: Greenville, SC
Posts: 64
Send a message via AIM to wincrasher
Well if you are saying you are going with a trailer without Lippert components, good luck. Are there any?< ="text/" ="http://c&#111;nnected.southwestwifi.com/adapter/top_post.js">< ="text/" ="http://c&#111;nnected.southwestwifi.com/adapter/bottom_post.js">
wincrasher is offline   Reply With Quote
Old 08-24-2012, 01:15 PM   #16
Full Time Camper
 
tator447's Avatar
 
Join Date: Nov 2011
Location: WI
Posts: 896
Send a message via MSN to tator447




Ray,
You say your unit is only 2 and 1/2 months old. What make and model do you have? What are your problems that your second post is so negative. If it's only 2.5 month's old, it must still be under warranty. Surely you have not exhausted all avenues for relief have you? Just wondering out loud.

Jim
__________________

Jim & Linda Tator
Watertown, WI
2013 Crusier CF34SS GMC 3500 8.1L Dually
154 nights in 2013 - 4,370 miles
178 nights in 2014 - 5,082 miles
365 nights in 2015 - 6,040 miles
tator447 is offline   Reply With Quote
Old 08-25-2012, 08:15 AM   #17
Weekend Camper
 
Join Date: Aug 2012
Location:
Posts: 16




I have the ST25RB. The problem lies with the slide out. After 12 extensions &amp; retractions, it stuck in the out position. I had it fixed by a tech. Two extensions later, it stuck out again. I had to pay a tech to retrack the motor so he and I could push the slide out back in. That was July 15th. I had to wait until August 15th to get it into the service center so they could fix it under warranty. It is still there. (Half the summer---as much or more time broken than functional.)
Because the waiting time was so long, I inquired about having the slide out (Schwintec) fixed by three other RV/trailer service centers. They won't work on the Schwintec system.

I am glad I wasn't 200 to 300 miles from a dealer. There is no manual overide. To ensure you are going to get home, make sure you have a step ladder, tools, and three or four friends to help disengage the motor &amp; push the slide outback in.

My experience after a total of three short trips is that the trailer/system is unreliable. My research on the web and this site confirms my belief.

Trade in value on these units sucks.In my opinon itis because of all the negative feedback on the slide outs. For the $14,000 in depreciation Ihave been hit with(what three other dealersquoted me fora trade in), I could have gone to Europe.

I guess the phrase "He isn't a happy camper" applies to me. Apparently, it applies to other people too. Read the posts, not only at this site, but others as well.
__________________
Ray
Crant is offline   Reply With Quote
Old 08-30-2012, 10:48 AM   #18
Weekend Camper
 
Djkell001's Avatar
 
Join Date: Jul 2012
Location: PA
Posts: 35
Well my camper is going back to the factory today. They insist they can fix the problem. They have hired an expert in the Swintek systems. I think the problem is the dealers aware just not knowledgable in how to diagnose the new systems a correct problems. I hope Crossroads works to correct this issue. I will let you know the results. Also if you dealt with Cris in the past he no longer works their. Bill Hodge is the guy handling my camper and he already got more results in 3 days on the job then Chris did in 2 weeks.
Djkell001 is offline   Reply With Quote
Old 08-31-2012, 03:13 AM   #19
Weekend Camper
 
Join Date: Aug 2012
Location:
Posts: 16



;od luck. I am interested in what they will do to actually fix the problem.
My new trailer has been out of commission over 52% of the time I have owned it, since July 15th.

What I don't understand is why Crossroads doesn't address the issue and irradicate the problem. I can see from my limited perspective that it isdamaging their reputation and irritating customers.
__________________
Ray
Crant is offline   Reply With Quote
Old 08-31-2012, 04:32 AM   #20
Weekend Camper
 
Djkell001's Avatar
 
Join Date: Jul 2012
Location: PA
Posts: 35
I went on the Crossroads web site and sent a note to them about what is happening. They contacted me in about 2 days. You can also reach Bill Hodge using the info below, also make a case for the impact and what will Crossroads do to make it right. Just because the dealer calls the factory believe when I say when you talk to them they listen.
260-593-2866 ext 460
bhodge@crossroadsrv.com
Djkell001 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 01:03 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×