Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-16-2018, 04:11 PM   #1
Family Vacation Member
 
Kingfish58's Avatar
 
Join Date: Aug 2014
Location: La.
Posts: 191
I知 stumped! Water issue...

Just hooked up at the campsite and repressurized my system after sanitizing yesterday and draining the bleach water out before the one hour trip this afternoon . All faucets are working, hot and cold, except for the kitchen faucet, hot and cold. Seems to be the end of the line, but I don稚 see any kinks or crimps in the lines I can see. All faucets worked yesterday when I ran the bleach water through the lines.

Any ideas are appreciated. Help!
Kingfish58 is offline   Reply With Quote
Old 02-16-2018, 04:34 PM   #2
Full Time Camper
 
Russb's Avatar
 
Join Date: Oct 2009
Location: Texas
Posts: 558
Possibly the faucet aerator is plugged.
__________________
Russ
Forney,TX
2010 Cruiser CTX CT29RLX
2009 F-150XLT
Russb is offline   Reply With Quote
Old 02-16-2018, 04:46 PM   #3
Family Vacation Member
 
Join Date: Dec 2015
Location: On
Posts: 158
Unscrew the faucet head. It may be full of debri.
Jeffur is offline   Reply With Quote
Old 02-16-2018, 05:11 PM   #4
Family Vacation Member
 
Kingfish58's Avatar
 
Join Date: Aug 2014
Location: La.
Posts: 191
That was it, thank you. Had to dig out the aerator plastic plug, then disconnect the hot and cold supply under the faucet to get the crud out. Kind of sandy, not sure what it was. Probably will be getting a new faucet with an easily rmoved aerator.
__________________
2015 Sunset Trail 270BH
2012 Toyota Tundra CrewMax 5.7L
Kingfish58 is offline   Reply With Quote
Old 02-16-2018, 05:36 PM   #5
Full Time Camper
 
Russb's Avatar
 
Join Date: Oct 2009
Location: Texas
Posts: 558
Quote:
Originally Posted by Kingfish58 View Post
That was it, thank you. Had to dig out the aerator plastic plug, then disconnect the hot and cold supply under the faucet to get the crud out. Kind of sandy, not sure what it was. Probably will be getting a new faucet with an easily rmoved aerator.
The sediment may be from the hot water heater, try flushing out the heater. Scale builds up from hard water. There is a special wand that fits in the drain plug hole that aids in the flush.
__________________
Russ
Forney,TX
2010 Cruiser CTX CT29RLX
2009 F-150XLT
Russb is offline   Reply With Quote
Old 02-16-2018, 07:28 PM   #6
Family Vacation Member
 
Kingfish58's Avatar
 
Join Date: Aug 2014
Location: La.
Posts: 191
Thanks Russ, I actually did that yesterday as well for the first time since I’ve owned the camper. I probably should have flushed it longer or left some debris in the tank.
__________________
2015 Sunset Trail 270BH
2012 Toyota Tundra CrewMax 5.7L
Kingfish58 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 08:22 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.