Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-09-2012, 11:11 AM   #1
Full Time Camper
 
artgpo's Avatar
 
Join Date: Jul 2009
Location: Texas
Posts: 780




Since mid-summer last year we have had an occasional sewer odor coming from the rear half bath. It seems as though the smell is under the fridge, above where the tank is situated. Since we have started using the RV this year the odor has gotten much more pronounced. This afternoon I decided to empty the rear black tank. All seemed fine until I turned on the tank flush. Water started coming out from thebottom of the Cruiser on the curb side and water was coming out of a joint on the drain pipe itself unless the water was running down the pipe from the curb side. I am thinking that when the rear flush was replaced under warranty two years ago the repair was done improperly. On Tuesday, a mobile repairman will be coming here to, hopefully, affect a repair.
__________________


Art and Karen
2013 Itasca Sunstar 35F, 2013 Ford C Max toad.
170 nights in 2013
132 in 2014
artgpo is offline   Reply With Quote
Old 03-09-2012, 07:14 PM   #2
Full Time Camper
 
Ruck's Avatar
 
Join Date: Apr 2011
Location: MYR
Posts: 535




Reckon you'll keep us posted inre the progress and result of the repair? Good luck ...
Travel Safe...
__________________
Travel Well / Travel Safe...
Ruck -n- Ella

'12 F350(NotShown) / '11 Rushmore 35RL
http://i53.tinypic.com/2qs5cw3.jpg
Ruck is offline   Reply With Quote
Old 03-09-2012, 08:51 PM   #3
Full Time Camper
 
Kamper Dave's Avatar
 
Join Date: Apr 2009
Location: WI
Posts: 510


It did not freeze did it? </span>



I always make sure there is a little antifreeze in the waste tanks

to safeguard those valves.</span>



</span>



The Backflow Preventer on the flush may be defective and squirting

water everywhere.</span>



The location of those preventers varies.</span>



</span>



Good luck.</span></span>
__________________
2010 CROSSROADS CRUISER CR31RE
2012 RAM 3500 ST + CHROME
Kamper Dave is offline   Reply With Quote
Old 03-14-2012, 12:00 AM   #4
Full Time Camper
 
artgpo's Avatar
 
Join Date: Jul 2009
Location: Texas
Posts: 780






Turns out the flush spray nozzle had broken off from the sprayer. This did two things.First, it permitted the wash out water to go every place other than the tank. Second, it permitted the black tank fumes to vent into the Cruiser. Blue Moon mobile repair guy will be back with parts today for the fix. Xtra Ride extended warranty paid for it all including the service call.

Edited by: artgpo
__________________


Art and Karen
2013 Itasca Sunstar 35F, 2013 Ford C Max toad.
170 nights in 2013
132 in 2014
artgpo is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 07:31 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.