Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-21-2017, 11:59 AM   #1
Weekend Camper
 
Join Date: Jun 2016
Location: AZ
Posts: 10
ST320BH Slide Seals falling off

Hello,

My slide seals are falling off and I can't figure out how to get them back on. They are the seals that run along the exterior of the trailer (not the slide) and function when the slide is closed. They look like they should slide on and remain in place but they keep falling off. I've attached a picture. It shows it coming loose and it will fall off the entire length of the seal. Any ideas?
Attached Images
File Type: jpg IMG_7552.jpg (89.9 KB, 27 views)
Spasm is offline   Reply With Quote
Old 05-21-2017, 12:16 PM   #2
New Camper
 
Join Date: Sep 2016
Location: IA
Posts: 5
That happens to me as well. I find you can snap them back into place. Hook one side in the groove and, with your thumb snap the other side into place.
rpadmore is offline   Reply With Quote
Old 05-21-2017, 12:25 PM   #3
Family Vacation Member
 
jimmerz's Avatar
 
Join Date: May 2015
Location: Pennsylvania
Posts: 107
Mine also. I used to be able snap them in but now that's not working so well. I think I need silicone?

Sent from my XT1585 using Tapatalk
__________________
2014 Ram Big Horn CC 1500 tow package, 3.92 gears.
2016 Crossroads ST270BH (June 18, 2015)
(2015: 7 nights camping, 425 miles) (lost track and became too lazy to update!)
jimmerz is offline   Reply With Quote
Old 05-21-2017, 02:04 PM   #4
Site Team
 
Join Date: Dec 2007
Location: WI.
Posts: 7,613
Can you put a screw thru it on the top end?
__________________
2008 Cruiser CF26RK
2013 Ford Eco-Boost
Heavy duty payload - Max tow
Lloyd is offline   Reply With Quote
Old 05-21-2017, 03:14 PM   #5
Full Time Camper
 
travelin texans's Avatar
 
Join Date: Feb 2016
Location: Texas
Posts: 1,021
You'll need some type of weather strip adhesive, I think you'll find silicone won't stick to those seals.
__________________
Danny & Linda
travelin texans is offline   Reply With Quote
Old 05-21-2017, 06:06 PM   #6
Seasonal Camper
 
sjk1998's Avatar
 
Join Date: Mar 2016
Location: Wi
Posts: 393
My seals were doing the same thing on our unit. I did what Travelin Texans did, I dabbed some 3M weather strip adhesive in a few spots on the track the put the seal back onto the track and haven't had a problem since.
__________________
Scott & Julie
Northern Wisconsin
2017 Sunset Trail 250RB
2015 F150 Supercrew w/3.5L EcoBoost/Max tow, w/
157 wheel base.
sjk1998 is offline   Reply With Quote
Old 05-22-2017, 07:54 AM   #7
Family Vacation Member
 
Join Date: Jul 2015
Location: Missouri
Posts: 144
I looked at mine this morning, and there are three screws (top, bottom and mid point) that must have been installed at the factory to hold the seal on.
__________________
2016 Sunset Trail 33BD
Tow Vehicle 2016 Nissan Titan XD 4x4, Crew Cab, SV with Cummins V-8
CFun is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Crossroads RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 05:11 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.